Lucene.Net
  1. Lucene.Net
  2. LUCENENET-445

Lucene.Net.Index.TestIndexWriter.TestFutureCommit() Fails

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: Lucene.Net 2.9.4
    • Fix Version/s: Lucene.Net 3.0.3
    • Component/s: None
    • Labels:
      None

      Description

      Fails with the following error:

      System.Collections.Generic.KeyNotFoundException was unhandled by user code
      Message=The given key was not present in the dictionary.
      Source=mscorlib
      StackTrace:
      at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
      at Lucene.Net.Index.TestIndexWriter.TestFutureCommit() in C:\Users\GeoBMX540\Desktop\Trunk\test\core\Index\TestIndexWriter.cs:line 5969
      InnerException:

        Activity

        Christopher Currens added a comment -

        I saw this fail when trunk was in 2.9, but not since trunk was merged with the 3.x branch, clearly some change caused this test to now pass. I this it's safe to close this issue.

        michael herndon added a comment -

        I've seen this one. Its one of those bugs that wasn't consistently reproduced and crops up every so often.

        Christopher Currens added a comment -

        This doesn't fail in Debug or Release in the 3.0.3 branch. I'm not even sure if it still fails in 2.9.4? Can this be closed?

        Prescott Nasser added a comment -

        Runtime error - doesn't even complete the test (pass or fail)


          People

          • Assignee:
            Unassigned
            Reporter:
            Prescott Nasser
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development