Today a TermInSetQuery on field F and terms A, B, C returns this from toString:
But this gets misleading when you embed it in a BooleanQuery as a negated clause, which then renders like this:
Making it look like only the first clause is negated when in fact they all are.
So ... I'd like to instead change it to:
I know Query.toString is simply best-effort, is not guaranteed to make something you can then parse in any query parser back to itself, etc., but I think we should still try to make a string that is not misleading when humans stare at it?