Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-7446

Fix back-compat version check in addVersion helper script

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.5.4, 5.6, 6.0.2, 6.1.1, 6.2.1, 6.3, 7.0
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New, Patch Available

      Description

      As part of the 5.5.3 post-release process, I was trying to bump up the number to 5.5.4 on the release branch but ran into the following error:

      Traceback (most recent call last):
        File "dev-tools/scripts/addVersion.py", line 246, in <module>
          main()
        File "dev-tools/scripts/addVersion.py", line 221, in main
          if current_version.is_back_compat_with(c.version):
        File "/Users/anshumgupta/workspace/lucene-solr/dev-tools/scripts/scriptutil.py", line 75, in is_back_compat_with
          raise Exception('Back compat check disallowed for newer version: %s < %s' % (self, other))
      Exception: Back compat check disallowed for newer version: 5.5.3 < 5.5.4
      

      I think the check is wrong and should be reversed. I'll post a patch that I used to work around this but would be good to have more eyes on this before I commit this.

      [~steve_rowe]: Can you take a look at the patch as I guess you added this recently.

        Attachments

        1. LUCENE-7446.patch
          3 kB
          Steven Rowe
        2. LUCENE-7446.patch
          0.7 kB
          Anshum Gupta

          Activity

            People

            • Assignee:
              anshum Anshum Gupta
              Reporter:
              anshum Anshum Gupta
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: