Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-7128

Fix spatial and sandbox geo APIs to consistently take lat before lon

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.0, 6.1, 7.0
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      Right now sometimes it's lat, lon and other times it's lon, lat which
      is just asking for horrors of biblical proportions.

      I went through and carefully fixed them to take lat, lon in all places
      I could find, and renamed y -> lat and x -> lon. I also removed
      unused code, or code only called from tests: I think Lucene shouldn't
      just export spatial APIs unless we also ourselves need them for
      indexing and searching. Finally, I tried to shrink wrap the APIs,
      making previously public apis private if nobody external invoked them.

        Attachments

        1. LUCENE-7128.patch
          244 kB
          Michael McCandless

          Activity

            People

            • Assignee:
              mikemccand Michael McCandless
              Reporter:
              mikemccand Michael McCandless
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: