Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.0
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      Followup of LUCENE-7039.

      I started consolidating encode/decode functions into XYZField, but its still pretty messy. Specifically, duplicated code because indexer wants packed byte[] and queries want byte[][] and so on.

      We can do a bit more cleanup: by defining everything in terms of encodeDimension() and decodeDimension(). This way, the logic is only in one place.

      Also the new NumericUtils methods here are confusing I think. Its scary how they take a "dimensional index" when parsing from a byte[]. I think they should just take 'offset' and not try to be fancy, its easier to understand.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              rcmuir Robert Muir
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: