Lucene - Core
  1. Lucene - Core
  2. LUCENE-6945

factor out TestCorePlus(Queries|Extensions)Parser from TestParser, rename TestParser to TestCoreParser

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.5, 6.0
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      Tests for the xml query parser in SOLR-839 for example could then be extending the TestParser or TestCorePlusQueriesParser or TestCorePlusExtensionsParser depending on requirements.

      1. LUCENE-6945.patch
        7 kB
        Christine Poerschke

        Issue Links

          Activity

          Hide
          ASF subversion and git services added a comment -

          Commit 1721381 from Christine Poerschke in branch 'dev/trunk'
          [ https://svn.apache.org/r1721381 ]

          LUCENE-6945: factor out TestCorePlus(Queries|Extensions)Parser from TestParser

          Show
          ASF subversion and git services added a comment - Commit 1721381 from Christine Poerschke in branch 'dev/trunk' [ https://svn.apache.org/r1721381 ] LUCENE-6945 : factor out TestCorePlus(Queries|Extensions)Parser from TestParser
          Hide
          ASF subversion and git services added a comment -

          Commit 1721416 from Christine Poerschke in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1721416 ]

          LUCENE-6945: factor out TestCorePlus(Queries|Extensions)Parser from TestParser (merge in revision 1721381 from trunk)

          Show
          ASF subversion and git services added a comment - Commit 1721416 from Christine Poerschke in branch 'dev/branches/branch_5x' [ https://svn.apache.org/r1721416 ] LUCENE-6945 : factor out TestCorePlus(Queries|Extensions)Parser from TestParser (merge in revision 1721381 from trunk)
          Hide
          Christine Poerschke added a comment -

          Re-opening, I had also intended to rename TestParser to TestCoreParser since that is now its purpose and scope.

          Show
          Christine Poerschke added a comment - Re-opening, I had also intended to rename TestParser to TestCoreParser since that is now its purpose and scope.
          Hide
          ASF subversion and git services added a comment -

          Commit 1721526 from Christine Poerschke in branch 'dev/trunk'
          [ https://svn.apache.org/r1721526 ]

          LUCENE-6945: rename TestParser to TestCoreParser

          Show
          ASF subversion and git services added a comment - Commit 1721526 from Christine Poerschke in branch 'dev/trunk' [ https://svn.apache.org/r1721526 ] LUCENE-6945 : rename TestParser to TestCoreParser
          Hide
          ASF subversion and git services added a comment -

          Commit 1721543 from Christine Poerschke in branch 'dev/branches/branch_5x'
          [ https://svn.apache.org/r1721543 ]

          LUCENE-6945: rename TestParser to TestCoreParser (merge in revision 1721526 from trunk)

          Show
          ASF subversion and git services added a comment - Commit 1721543 from Christine Poerschke in branch 'dev/branches/branch_5x' [ https://svn.apache.org/r1721543 ] LUCENE-6945 : rename TestParser to TestCoreParser (merge in revision 1721526 from trunk)

            People

            • Assignee:
              Christine Poerschke
              Reporter:
              Christine Poerschke
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development