Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      Our BKD tree impl should be very fast at doing "distance from lat/lon center point < X" query.

      I haven't started this ... Nicholas Knize expressed interest in working on it.

      1. LUCENE-6698.patch
        47 kB
        Michael McCandless

        Activity

        mikemccand Michael McCandless added a comment -

        Nicholas Knize OK if I start working on this? Do you have a starting point?

        mikemccand Michael McCandless added a comment -

        Work-in-progress patch, but the test fails, I think because GeoUtils.rectCrossesCircle is buggy.

        I reduced it to this small test case which I think should pass, unless I'm using the {[GeoUtils}} API incorrectly?:

          public void testRectCrossesCircle() throws Exception {
            assertTrue(GeoUtils.rectCrossesCircle(-180, -90, 180, 0.0, 0.667, 0.0, 88000.0));
          }
        
        jira-bot ASF subversion and git services added a comment -

        Commit 1703282 from Michael McCandless in branch 'dev/branches/lucene6780'
        [ https://svn.apache.org/r1703282 ]

        LUCENE-6698, LUCENE-6780: add BKDDistanceQuery

        mikemccand Michael McCandless added a comment -

        I committed the current patch on the https://svn.apache.org/repos/asf/lucene/dev/branches/lucene6780 branch but the test is still failing ... but TestGeoPointQuery seems to be failing in the same way when I make its test similarly evil, so hopefully there is a single root cause

        nknize Nicholas Knize added a comment -

        Duplicated and resolved by LUCENE-7054


          People

          • Assignee:
            mikemccand Michael McCandless
            Reporter:
            mikemccand Michael McCandless
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development