Lucene - Core
  1. Lucene - Core
  2. LUCENE-6634

PKIndexSplitter should take queries, not filters

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.3
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      We could make PKIndexSplitter work on the Query API instead of Filter. This way lucene/misc would not depend on oal.search.Filter anymore.

      1. LUCENE-6634.patch
        6 kB
        Adrien Grand
      2. LUCENE-6634.patch
        5 kB
        Adrien Grand

        Activity

        Hide
        Adrien Grand added a comment -

        Here is a patch. The change is backward compatible since Filter extends Query.

        Show
        Adrien Grand added a comment - Here is a patch. The change is backward compatible since Filter extends Query.
        Hide
        Uwe Schindler added a comment -

        Looks fine. Change is almost backwards compatible (but you need to recompile for correct method signatures). So maybe add the Filter constructor (just deprecate) for full backwards compatibility.

        Show
        Uwe Schindler added a comment - Looks fine. Change is almost backwards compatible (but you need to recompile for correct method signatures). So maybe add the Filter constructor (just deprecate) for full backwards compatibility.
        Hide
        Adrien Grand added a comment -

        OK, I will do that when merging to 5.x. Thanks for having a look!

        Show
        Adrien Grand added a comment - OK, I will do that when merging to 5.x. Thanks for having a look!
        Hide
        Uwe Schindler added a comment -

        Maybe you rename the local variables, partially they are still named preserveFilter instead of preserveWeight,... But thats just for consistency.

        Thanks for having a look!

        I had to, I wrote that code back in Lucene 3.x and modified for 4.0

        Show
        Uwe Schindler added a comment - Maybe you rename the local variables, partially they are still named preserveFilter instead of preserveWeight,... But thats just for consistency. Thanks for having a look! I had to, I wrote that code back in Lucene 3.x and modified for 4.0
        Hide
        Adrien Grand added a comment -

        I changed the name to preserveWeight when it becomes a Weight. However I kept preserveFilter when it is still a Query as I think it nicely conveys the fact that scores won't be used?

        Show
        Adrien Grand added a comment - I changed the name to preserveWeight when it becomes a Weight. However I kept preserveFilter when it is still a Query as I think it nicely conveys the fact that scores won't be used?
        Hide
        ASF subversion and git services added a comment -

        Commit 1688365 from Adrien Grand in branch 'dev/trunk'
        [ https://svn.apache.org/r1688365 ]

        LUCENE-6634: PKIndexSplitter now takes a Query instead of a Filter.

        Show
        ASF subversion and git services added a comment - Commit 1688365 from Adrien Grand in branch 'dev/trunk' [ https://svn.apache.org/r1688365 ] LUCENE-6634 : PKIndexSplitter now takes a Query instead of a Filter.
        Hide
        ASF subversion and git services added a comment -

        Commit 1688368 from Adrien Grand in branch 'dev/branches/branch_5x'
        [ https://svn.apache.org/r1688368 ]

        LUCENE-6634: PKIndexSplitter now takes a Query instead of a Filter.

        Show
        ASF subversion and git services added a comment - Commit 1688368 from Adrien Grand in branch 'dev/branches/branch_5x' [ https://svn.apache.org/r1688368 ] LUCENE-6634 : PKIndexSplitter now takes a Query instead of a Filter.
        Hide
        Uwe Schindler added a comment -

        Thanks!

        Show
        Uwe Schindler added a comment - Thanks!
        Hide
        Shalin Shekhar Mangar added a comment -

        Bulk close for 5.3.0 release

        Show
        Shalin Shekhar Mangar added a comment - Bulk close for 5.3.0 release

          People

          • Assignee:
            Adrien Grand
            Reporter:
            Adrien Grand
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development