Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.0
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      Now that BooleanQuery can handle filters, FilteredQuery should be removed in trunk and deprecated in 5.x.

      1. LUCENE-6583.patch
        158 kB
        Adrien Grand

        Activity

        Adrien Grand added a comment -

        Here is a patch. Most of it is about simply replacing FilteredQuery with BooleanQuery. However, I had to slightly change the Filter class so that it can choose whether it should be applied eagerly (through the iterator) or lazily (through the bits) when consumed through the Query API. This was useful to keep the lucene/facets and lucene/spatial modules working since they build filters that should always be consumed after the query.

        ASF subversion and git services added a comment -

        Commit 1686203 from Adrien Grand in branch 'dev/trunk'
        [ https://svn.apache.org/r1686203 ]

        LUCENE-6583: Remove FilteredQuery.

        ASF subversion and git services added a comment -

        Commit 1686206 from Adrien Grand in branch 'dev/branches/branch_5x'
        [ https://svn.apache.org/r1686206 ]

        LUCENE-6583: Deprecate FilteredQuery in 5.x.

        Hoss Man added a comment - - edited

        Adrien: your trunk commit seems to be causing a lot of reproducible failures in Solr's BJQParserTest (see linked SOLR-7706)

        Adrien Grand added a comment -

        Thanks for the ping, I missed it. I'll dig.


          People

          • Assignee:
            Adrien Grand
            Reporter:
            Adrien Grand
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development