Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.1, 6.0
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      We have TermRangeFilter, NumericRangeFilter, ... that we should remove in favour of their equivalent queries (TermRangeQuery, NumericRangeQuery, ...).

      1. LUCENE-6300.patch
        195 kB
        Adrien Grand
      2. LUCENE-6300.patch
        120 kB
        Adrien Grand

        Activity

        Hide
        jpountz Adrien Grand added a comment -

        Here is a patch.

        Show
        jpountz Adrien Grand added a comment - Here is a patch.
        Hide
        thetaphi Uwe Schindler added a comment -

        We should maybe rename MultiTermQueryWrapperFilter to MultiTermQueryWrapper and the rewrite mode to just CONSTANT_SCORE.

        Show
        thetaphi Uwe Schindler added a comment - We should maybe rename MultiTermQueryWrapperFilter to MultiTermQueryWrapper and the rewrite mode to just CONSTANT_SCORE.
        Hide
        jpountz Adrien Grand added a comment -

        Good idea, I was lacking inspiration when I worked on the patch but I like your suggestion!

        Show
        jpountz Adrien Grand added a comment - Good idea, I was lacking inspiration when I worked on the patch but I like your suggestion!
        Hide
        jpountz Adrien Grand added a comment -

        New patch:

        • also fixes doc-values rewrite
        • renames MultiTermQueryWrapperFilter to MultiTermQueryConstantScoreWrapper
        • renames rewrite methods constants to remove "QUERY" or "FILTER" from the name since we now only have queries
        Show
        jpountz Adrien Grand added a comment - New patch: also fixes doc-values rewrite renames MultiTermQueryWrapperFilter to MultiTermQueryConstantScoreWrapper renames rewrite methods constants to remove "QUERY" or "FILTER" from the name since we now only have queries
        Hide
        jira-bot ASF subversion and git services added a comment -

        Commit 1662682 from Adrien Grand in branch 'dev/trunk'
        [ https://svn.apache.org/r1662682 ]

        LUCENE-6300: Remove multi-term filters.

        Show
        jira-bot ASF subversion and git services added a comment - Commit 1662682 from Adrien Grand in branch 'dev/trunk' [ https://svn.apache.org/r1662682 ] LUCENE-6300 : Remove multi-term filters.
        Hide
        jira-bot ASF subversion and git services added a comment -

        Commit 1662740 from Adrien Grand in branch 'dev/branches/branch_5x'
        [ https://svn.apache.org/r1662740 ]

        LUCENE-6300: Remove multi-term filters.

        Show
        jira-bot ASF subversion and git services added a comment - Commit 1662740 from Adrien Grand in branch 'dev/branches/branch_5x' [ https://svn.apache.org/r1662740 ] LUCENE-6300 : Remove multi-term filters.
        Hide
        thelabdude Timothy Potter added a comment -

        Bulk close after 5.1 release

        Show
        thelabdude Timothy Potter added a comment - Bulk close after 5.1 release

          People

          • Assignee:
            jpountz Adrien Grand
            Reporter:
            jpountz Adrien Grand
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development