Lucene - Core
  1. Lucene - Core
  2. LUCENE-5965

Make CorruptIndexException require 'resource' like TooOld/TooNew do

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.0, 6.0
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      and review all of these to ensure other pertinent information is included.

      1. LUCENE-5965.patch
        107 kB
        Robert Muir

        Activity

        Hide
        Michael McCandless added a comment -

        +1

        Show
        Michael McCandless added a comment - +1
        Hide
        Robert Muir added a comment -

        Patch requiring resourceDescription (either datainput, or string). We had quite a few places missing this.

        Show
        Robert Muir added a comment - Patch requiring resourceDescription (either datainput, or string). We had quite a few places missing this.
        Hide
        Uwe Schindler added a comment -

        +1 for this!

        Show
        Uwe Schindler added a comment - +1 for this!
        Hide
        Michael McCandless added a comment -

        +1, looks awesome.

        Show
        Michael McCandless added a comment - +1, looks awesome.
        Hide
        ASF subversion and git services added a comment -

        Commit 1626372 from Robert Muir in branch 'dev/trunk'
        [ https://svn.apache.org/r1626372 ]

        LUCENE-5965: CorruptIndexException requires a String or DataInput resource

        Show
        ASF subversion and git services added a comment - Commit 1626372 from Robert Muir in branch 'dev/trunk' [ https://svn.apache.org/r1626372 ] LUCENE-5965 : CorruptIndexException requires a String or DataInput resource
        Hide
        ASF subversion and git services added a comment -

        Commit 1626375 from Robert Muir in branch 'dev/branches/branch_5x'
        [ https://svn.apache.org/r1626375 ]

        LUCENE-5965: CorruptIndexException requires a String or DataInput resource

        Show
        ASF subversion and git services added a comment - Commit 1626375 from Robert Muir in branch 'dev/branches/branch_5x' [ https://svn.apache.org/r1626375 ] LUCENE-5965 : CorruptIndexException requires a String or DataInput resource
        Hide
        Anshum Gupta added a comment -

        Bulk close after 5.0 release.

        Show
        Anshum Gupta added a comment - Bulk close after 5.0 release.

          People

          • Assignee:
            Unassigned
            Reporter:
            Robert Muir
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development