Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-5865

create fork of analyzers module without Version

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 4.10
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      Since this is obviously too controversial to fix, we can just add alternatives that don't have this messy api, e.g. under analyzers-simple.

      These won't have Version. They don't need factories, because they are actually geared at being usable for lucene users.

      Once nice thing is, this way the problem can be fixed in 4.10

        Attachments

        1. LUCENE-5865.patch
          8.49 MB
          Robert Muir

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              rcmuir Robert Muir
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: