Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-5710

DefaultIndexingChain swallows useful information from MaxBytesLengthExceededException

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 4.8.1
    • Fix Version/s: 4.9, 6.0
    • Component/s: core/index
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      In DefaultIndexingChain, when a MaxBytesLengthExceededException is caught, the original message is discarded, however, the message contains useful information like the size that exceeded the limit.

      Lucene should make this information included in the newly thrown IllegalArgumentException.

      1. LUCENE-5710.patch
        3 kB
        Lee Hinman
      2. LUCENE-5710.patch
        2 kB
        Lee Hinman

        Activity

        dakrone Lee Hinman added a comment -

        Attaching patch that includes the original exception's message in the IllegalArgumentException message.

        dakrone Lee Hinman added a comment -

        Patch that includes the exception as the cause parameter for IllegalArgumentException

        mikemccand Michael McCandless added a comment -

        Thanks Lee, this looks great, I'll commit shortly!

        jira-bot ASF subversion and git services added a comment -

        Commit 1598275 from Michael McCandless in branch 'dev/trunk'
        [ https://svn.apache.org/r1598275 ]

        LUCENE-5710: don't swallow innner immense term exception

        mikemccand Michael McCandless added a comment -

        Resolved from Dublin, where the US blob has free WiFi!

        rcmuir Robert Muir added a comment -

        I don't see a 4.x commit for this.

        mikemccand Michael McCandless added a comment -

        Woops ... I'll commit to 4.x. Dublin also had beer, perhaps too much...

        jira-bot ASF subversion and git services added a comment -

        Commit 1598514 from Michael McCandless in branch 'dev/branches/branch_4x'
        [ https://svn.apache.org/r1598514 ]

        LUCENE-5710: don't swallow inner immense term exception

        mikemccand Michael McCandless added a comment -

        OK, I backported ... thanks Rob.


          People

          • Assignee:
            Unassigned
            Reporter:
            dakrone Lee Hinman
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development