Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-5614

Add workaround for ANT bug to enable compile with Java 8 on ANT 1.8.3. and 1.8.4

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.8, 4.9, 6.0
    • Component/s: general/build
    • Labels:
    • Lucene Fields:
      New

      Description

      Ant has the following bug introduced in ANT 1.8.3 and 1.8.4. Unfortunately many computers are on this version (and MacOSX on 1.8.2):
      https://issues.apache.org/bugzilla/show_bug.cgi?id=53347

      I would like to change to minimum ANT 1.9.0, but this would make MacOSX user unhappy. The provided patch is a workaround to set the compiler version to "javac1.7" via ANT property, if the broken versions are used with Java 1.8.

        Attachments

        1. LUCENE-5614.patch
          0.8 kB
          Uwe Schindler

          Activity

            People

            • Assignee:
              thetaphi Uwe Schindler
              Reporter:
              thetaphi Uwe Schindler
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: