Lucene - Core
  1. Lucene - Core
  2. LUCENE-5322

Clean up / simplify Maven-related Ant targets

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.7, 6.0
    • Component/s: general/build
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      Many Maven-related Ant targets are public when they don't need to be, e.g. dist-maven and filter-pom-templates, m2-deploy-lucene-parent-pom, etc.

      The arrangement of these targets could be simplified if the directories that have public entry points were minimized.

      generate-maven-artifacts should be runnable from the top level and from lucene/ and solr/.

      1. LUCENE-5322.lucene-javadoc-url.fix.patch
        2 kB
        Steve Rowe
      2. LUCENE-5322.patch
        13 kB
        Steve Rowe
      3. LUCENE-5322.validate-maven-artifacts.patch
        2 kB
        Steve Rowe

        Activity

        Steve Rowe added a comment -

        Patch.

        Targets that don't need to be public are made private.

        Each of the three versions of generate-maven-artifacts makes sure that resolve, unpack(lucene and or solr)-tgz, and -filter-pom-templates is called. Then recursive non-public -dist-maven doesn't have to worry about these things being done.

        This patch also fixes the problem introduced by LUCENE-5217 with resolve not being called before get-maven-poms and filter-pom-templates.

        I'll commit this to trunk shortly, then to branch_4x after LUCENE-5217 has been committed to branch_4x, in a few days.

        ASF subversion and git services added a comment -

        Commit 1538144 from Steve Rowe in branch 'dev/trunk'
        [ https://svn.apache.org/r1538144 ]

        LUCENE-5322: Clean up / simplify Maven-related Ant targets

        Steve Rowe added a comment - - edited

        Committed to trunk.

        ant nightly-smoke, ant generate-maven-artifacts (at all three locations), ant validate-maven-artifacts and ant get-maven-poms all succeed for me locally.

        Steve Rowe added a comment - - edited

        Currently validate-maven-artifacts invokes filter-pom-templates once per POM, which is way too much; also, validate-maven-artifacts depends on generate-maven-artifacts, even though it only needs the filtered POMs, and not the built artifacts.

        This patch fixes both issues.

        Committing shortly.

        ASF subversion and git services added a comment -

        Commit 1540832 from Steve Rowe in branch 'dev/trunk'
        [ https://svn.apache.org/r1540832 ]

        LUCENE-5322: make 'ant validate-maven-artifacts' run faster

        ASF subversion and git services added a comment -

        Commit 1540846 from Steve Rowe in branch 'dev/trunk'
        [ https://svn.apache.org/r1540846 ]

        LUCENE-5322: 'ant validate-maven-artifacts' should depend on 'generate-maven-artifacts'

        ASF subversion and git services added a comment -

        Commit 1540849 from Steve Rowe in branch 'dev/trunk'
        [ https://svn.apache.org/r1540849 ]

        LUCENE-5322: 'ant validate-maven-dependencies' doesn't need to call 'filter-pom-templates' directly, since 'generate-maven-artifacts' already does it

        ASF subversion and git services added a comment -

        Commit 1541355 from Steve Rowe in branch 'dev/trunk'
        [ https://svn.apache.org/r1541355 ]

        Move LUCENE-5217 and LUCENE-5322 entries to the 4.7 section

        ASF subversion and git services added a comment -

        Commit 1541357 from Steve Rowe in branch 'dev/branches/branch_4x'
        [ https://svn.apache.org/r1541357 ]

        Backport LUCENE-5217 and LUCENE-5322 to branch_4x

        Steve Rowe added a comment -

        ant nightly-smoke failed on branch_4x because of a permgen OOM: https://builds.apache.org/job/Lucene-Solr-SmokeRelease-4.x/125/

        I chatted with Uwe Schindler on #lucene-dev IRC, and he thinks the issue is that groovy is being resolved more than once, in order to define lucene.javadoc.url, and it should only be done once.

        This patch fixes the problem: -dist-maven in solr/build.xml now depends on define-lucene-javadoc-url, and passes uptodate.and.compiled.properties, which includes lucene.javadoc.url, down the call chain.

        Committing shortly.

        ASF subversion and git services added a comment -

        Commit 1541653 from Steve Rowe in branch 'dev/trunk'
        [ https://svn.apache.org/r1541653 ]

        LUCENE-5322: define-lucene-javadoc-url should only be called once as part of Solr's generate-maven-artifacts

        ASF subversion and git services added a comment -

        Commit 1541654 from Steve Rowe in branch 'dev/branches/branch_4x'
        [ https://svn.apache.org/r1541654 ]

        LUCENE-5322: define-lucene-javadoc-url should only be called once as part of Solr's generate-maven-artifacts (merged trunk r1541653)


          People

          • Assignee:
            Steve Rowe
            Reporter:
            Steve Rowe
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development