Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-4763

Fix Java version detection in common-build.xml, use correct source version for javadocs, fail build on unsupported java version when documentation linting is enabled

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 4.1
    • 4.2, 6.0
    • general/build
    • None
    • New

    Description

      Followup after the discussion on mailing list; this issue tries to fix the following problems in the ANT build:

      • ${ant.java.version} is incorrect for Java 8 with ANT < 1.8.3 (it says its Java 7, so we habve otherwise no chance to detect java 8). This can be fixed by the same set of reflection tests from Constants.java. We can also fail build early if somebody uses Java 1.5
      • javadoc macro uses this incorrect ant.java.version property to execute javadocs. The source attribute of the javac task must be ${javac.source} (like javac)
      • If we run builds by Jenkins, we silently disable targets that cannot be executed. This has effects on real developers. If a real person executes the ant tasks it should not pass silently, it should tell the user that his configuration is unsupported. This can be done by passing a hidden "jenkins-build" property down.

      Attachments

        1. LUCENE-4763.patch
          8 kB
          Uwe Schindler

        Activity

          People

            uschindler Uwe Schindler
            uschindler Uwe Schindler
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: