Lucene - Core
  1. Lucene - Core
  2. LUCENE-4407

XML-forbidden unicode characters break XML test reports

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0, 6.0
    • Component/s: general/test
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      Disallowed by spec. XML unicode characters (in Strings) produce invalid XML reports which then fail on jenkins.

      I think this would also be the case with regular ant/maven runners but I didn't check. It'd be interesting to see if they cater for this somehow.

        Activity

        Dawid Weiss added a comment -

        This is tricky to fix, actually. I patched the serializer and tests pass in rr 2.0.1. I've pushed the release, will upgrade Lucene soon.

        Dawid Weiss added a comment -

        Should be fine now (with invalid characters at least). Note that XML output is not able to reproduce console output verbatim because of this.

        Commit Tag Bot added a comment -

        [branch_4x commit] Dawid Weiss
        http://svn.apache.org/viewvc?view=revision&revision=1387589

        LUCENE-4406, LUCENE-4407: Upgrade to randomizedtesting 2.0.1.
        Workaround for broken test output XMLs due to non-XML text unicode
        chars in strings. Added printing of failed tests at the end of a
        test run (Dawid Weiss)

        Uwe Schindler added a comment -

        Closed after release.


          People

          • Assignee:
            Dawid Weiss
            Reporter:
            Dawid Weiss
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development