Lucene - Core
  1. Lucene - Core
  2. LUCENE-4307

rename IR.getTopReaderContext to IR.getContext

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0, 6.0
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      IR/IS.getTopReaderContext is supposed to read as "get the ReaderContext, with this reader treated as the top".

      But every time I look at it, it reads as "get context of the top-level reader".

      This makes sense for IndexSearcher, but is confusing for IndexReader.

      I think it should simply be IR.getContext() for IndexReader.

        Activity

        Hide
        Michael McCandless added a comment -

        +1

        Show
        Michael McCandless added a comment - +1
        Hide
        Uwe Schindler added a comment -

        +1

        Show
        Uwe Schindler added a comment - +1
        Hide
        Uwe Schindler added a comment -

        Closed after release.

        Show
        Uwe Schindler added a comment - Closed after release.

          People

          • Assignee:
            Unassigned
            Reporter:
            Robert Muir
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development