Lucene - Core
  1. Lucene - Core
  2. LUCENE-4070

TestIndexWriter.testThreadInterruptDeadlock failure

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: 4.0-ALPHA
    • Component/s: core/store
    • Labels:
      None
    • Lucene Fields:
      New, Patch Available
    1. LUCENE-4070.patch
      1 kB
      Simon Willnauer

      Activity

      Simon Willnauer added a comment -

      committed to trunk

      Robert Muir added a comment -

      +1

      Simon Willnauer added a comment -

      here is a possible patch

      Simon Willnauer added a comment -

      TestIndexWriter.testThreadInterruptDeadlock failed on jenkins with this error:

      FAILED; unexpected exception
      java.io.IOException: file "_1o.cfs" was already written to
      	at org.apache.lucene.store.MockDirectoryWrapper.createOutput(MockDirectoryWrapper.java:437)
      	at org.apache.lucene.store.CompoundFileWriter.getOutput(CompoundFileWriter.java:124)
      	at org.apache.lucene.store.CompoundFileWriter.close(CompoundFileWriter.java:166)
      	at org.apache.lucene.store.CompoundFileDirectory.close(CompoundFileDirectory.java:235)
      	at org.apache.lucene.util.IOUtils.closeWhileHandlingException(IOUtils.java:80)
      	at org.apache.lucene.index.IndexWriter.prepareFlushedSegment(IndexWriter.java:1983)
      	at org.apache.lucene.index.DocumentsWriter.publishFlushedSegment(DocumentsWriter.java:497)
      	at org.apache.lucene.index.DocumentsWriter.finishFlush(DocumentsWriter.java:477)
      	at org.apache.lucene.index.DocumentsWriterFlushQueue$SegmentFlushTicket.publish(DocumentsWriterFlushQueue.java:201)
      	at org.apache.lucene.index.DocumentsWriterFlushQueue.innerPurge(DocumentsWriterFlushQueue.java:119)
      	at org.apache.lucene.index.DocumentsWriterFlushQueue.tryPurge(DocumentsWriterFlushQueue.java:148)
      	at org.apache.lucene.index.DocumentsWriter.doFlush(DocumentsWriter.java:438)
      	at org.apache.lucene.index.DocumentsWriter.flushAllThreads(DocumentsWriter.java:553)
      	at org.apache.lucene.index.IndexWriter.prepareCommit(IndexWriter.java:2416)
      	at org.apache.lucene.index.IndexWriter.commitInternal(IndexWriter.java:2548)
      	at org.apache.lucene.index.IndexWriter.commit(IndexWriter.java:2530)
      	at org.apache.lucene.index.IndexWriter.commit(IndexWriter.java:2514)
      	at org.apache.lucene.index.TestIndexWriter$IndexerThreadInterrupt.run(TestIndexWriter.java:1072)
      
      reproduce with: ant test -Dtestcase=TestIndexWriter -Dtests.method=testThreadInterruptDeadlock -Dtests.seed=4DBD057B5EE19CD9 -Dtests.locale=es_GT -Dtests.timezone=US/Eastern -Dtests.multiplier=3 -Dargs="-Dfile.encoding=UTF-8"
      

      this seems caused by a deferred assignment in the CFS writer when opening the output stream


        People

        • Assignee:
          Simon Willnauer
          Reporter:
          Simon Willnauer
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development