Lucene - Core
  1. Lucene - Core
  2. LUCENE-3970

Rename getUnique[Field/Terms]Count() into size()

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0-ALPHA
    • Component/s: core/index
    • Labels:
      None
    • Lucene Fields:
      Patch Available

      Description

      Like Robert Muir said in LUCENE-3109:

      Also I think there are other improvements we can do here that would be more natural:
      Fields.getUniqueFieldCount() -> Fields.size()
      Terms.getUniqueTermCount() -> Terms.size()

      I believe this dramatically improves understandability (way less 'scary', actually beautiful).

        Activity

        Hide
        Michael McCandless added a comment -

        Thanks Iulius, this looks good ... I'll commit shortly.

        Show
        Michael McCandless added a comment - Thanks Iulius, this looks good ... I'll commit shortly.
        Hide
        Michael McCandless added a comment -

        Thanks Iulius!

        Show
        Michael McCandless added a comment - Thanks Iulius!

          People

          • Assignee:
            Michael McCandless
            Reporter:
            Iulius Curt
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development