Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Hello,

      Could you please advise how this issue:

      TP-Processor13 ERROR [com.atlassian.bonnie.ConcurrentLuceneConnection] Error closing writer. java.io.FileNotFoundException: /opt/jira/indexes/comments/_4ubij.fnm (No such file or directory)
      java.io.FileNotFoundException: /opt/jira/indexes/comments/_4ubij.fnm (No such file or directory)

      Thread-228 ERROR [atlassian.core.user.UserUtils] [Ljava.lang.StackTraceElement;@258e5d0e

      Thread-228 ERROR [event.listeners.search.IssueIndexListener] Error re-indexing changes for issue 'current issue'
      com.atlassian.jira.issue.index.IndexException: com.atlassian.bonnie.LuceneException: org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out: SimpleFSLock@/opt/jira/indexes/comments/write.lock

      can be resolved in JIRA.

      I've deleted the write.lock file from directory /opt/jira/indexes/comments/ and restarted JIRA but it did not help. The problem with Lucene still exists.

      Please advise what caused the problem and how it can be avoid in the future and what is more important how this Lucene Exception can be resolved.

      Regards,

      Dylan

        Activity

        Uwe Schindler added a comment -

        Please contact Atlassian support about JIRA issues! This may be caused by JIRAs indexer.

        I can only suggest:

        • Delete the whole index from disk and trigger a reindex in JIRA
        • Make sure that the index is not placed on a remote disk (e.g. NFS filesystem)
        Erick Erickson added a comment -

        Happened across this and it doesn't seem useful to keep open.


          People

          • Assignee:
            Unassigned
            Reporter:
            Dylan SD
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development