Lucene - Core
  1. Lucene - Core
  2. LUCENE-3933

Cloneable classes can use their class in the clone() function

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Since Java5, we are allowed to use an explicit class when returning clone()

      It is nicer to use:

      OpenBitSet copy = original.clone();
      

      then

      OpenBitSet copy = (OpenBitSet)original.clone();
      

        Activity

        Robert Muir added a comment -

        This is a duplicate of LUCENE-2000


          People

          • Assignee:
            Ryan McKinley
            Reporter:
            Ryan McKinley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development