Lucene - Core
  1. Lucene - Core
  2. LUCENE-3871

Stack traces from failed tests are messed up on ANT 1.7.x

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.6, 4.0-ALPHA
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Activity

      Dawid Weiss added a comment -

      I can't reproduce this. My stack trace is fine:

      junit-sequential:
          [junit] Testsuite: org.apache.lucene.search.grouping.AllGroupHeadsCollectorTest
          [junit] Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 4.704 sec
          [junit]
          [junit] ------------- Standard Error -----------------
          [junit] NOTE: reproduce with: ant test -Dtestcase=AllGroupHeadsCollectorTest -Dtestmethod=testRandom -Dtests.seed=-770badc2509
      9b45c:-33bf9d8d527fecf3:-6ba7b68007c53875 -Dtests.multiplier=3 -Dargs="-Dfile.encoding=ISO8859-1"
          [junit] NOTE: test params are: codec=Lucene40: {sort3=PostingsFormat(name=MockRandom), id=Pulsing40(freqCutoff=9 minBlockSize=
      79 maxBlockSize=251), content=PostingsFormat(name=Memory doPackFST= true), sort2=Lucene40(minBlockSize=12 maxBlockSize=46), sort1=
      PostingsFormat(name=NestedPulsing), group=PostingsFormat(name=NestedPulsing)}, sim=DefaultSimilarity, locale=es_CL, timezone=Ameri
      ca/Chicago
          [junit] NOTE: all tests run in this JVM:
          [junit] [AllGroupHeadsCollectorTest]
          [junit] NOTE: Windows 7 6.1 amd64/Oracle Corporation 1.7.0_01 (64-bit)/cpus=8,threads=1,free=155882936,total=226754560
          [junit] ------------- ---------------- ---------------
          [junit] Testcase: testRandom(org.apache.lucene.search.grouping.AllGroupHeadsCollectorTest): FAILED
          [junit] null
          [junit] junit.framework.AssertionFailedError
          [junit]     at org.apache.lucene.util.PagedBytes$Reader.fillSliceWithPrefix(PagedBytes.java:212)
          [junit]     at org.apache.lucene.codecs.lucene40.values.VarDerefBytesImpl$VarDerefSource.getBytes(VarDerefBytesImpl.java:124)
          [junit]     at org.apache.lucene.search.grouping.dv.DVAllGroupHeadsCollector$GeneralAllGroupHeadsCollector$BR.getGroupValue(DV
      AllGroupHeadsCollector.java:252)
          [junit]     at org.apache.lucene.search.grouping.dv.DVAllGroupHeadsCollector$GeneralAllGroupHeadsCollector.retrieveGroupHeadAn
      dAddIfNotExist(DVAllGroupHeadsCollector.java:177)
          [junit]     at org.apache.lucene.search.grouping.AbstractAllGroupHeadsCollector.collect(AbstractAllGroupHeadsCollector.java:10
      3)
          [junit]     at org.apache.lucene.search.Scorer.score(Scorer.java:60)
          [junit]     at org.apache.lucene.search.IndexSearcher.search(IndexSearcher.java:508)
          [junit]     at org.apache.lucene.search.IndexSearcher.search(IndexSearcher.java:297)
          [junit]     at org.apache.lucene.search.grouping.AllGroupHeadsCollectorTest.testRandom(AllGroupHeadsCollectorTest.java:320)
          [junit]     at org.apache.lucene.util.LuceneTestCase$SubclassSetupTeardownRule$1.evaluate(LuceneTestCase.java:729)
          [junit]     at org.apache.lucene.util.LuceneTestCase$InternalSetupTeardownRule$1.evaluate(LuceneTestCase.java:645)
          [junit]     at org.apache.lucene.util.SystemPropertiesInvariantRule$1.evaluate(SystemPropertiesInvariantRule.java:22)
          [junit]     at org.apache.lucene.util.LuceneTestCase$TestResultInterceptorRule$1.evaluate(LuceneTestCase.java:556)
          [junit]     at org.apache.lucene.util.UncaughtExceptionsRule$1.evaluate(UncaughtExceptionsRule.java:51)
          [junit]     at org.apache.lucene.util.LuceneTestCase$RememberThreadRule$1.evaluate(LuceneTestCase.java:618)
          [junit]     at org.apache.lucene.util.LuceneTestCaseRunner.runChild(LuceneTestCaseRunner.java:164)
          [junit]     at org.apache.lucene.util.LuceneTestCaseRunner.runChild(LuceneTestCaseRunner.java:57)
          [junit]     at org.apache.lucene.util.UncaughtExceptionsRule$1.evaluate(UncaughtExceptionsRule.java:51)
          [junit]     at org.apache.lucene.util.StoreClassNameRule$1.evaluate(StoreClassNameRule.java:21)
          [junit]     at org.apache.lucene.util.SystemPropertiesInvariantRule$1.evaluate(SystemPropertiesInvariantRule.java:22)
          [junit]
          [junit]
          [junit] Test org.apache.lucene.search.grouping.AllGroupHeadsCollectorTest FAILED
      
      Dawid Weiss added a comment -

      May this be caused by ANT? I'm running 1.8.2 and I don't see any weirdness.

      Dawid Weiss added a comment -

      Confirmed – this is some weirdness in ANT 1.7.x. Yet another reason to upgrade to 1.8.x...

      Dawid Weiss added a comment -

      This is ANT 1.7.x doing something to stack traces; don't want to know what it does or why... I advocate for making 1.8 a requirement for compilation

      Michael McCandless added a comment -

      I will upgrade!

      Dawid Weiss added a comment -

      I dug a little deeper. The problem on ANT 1.7 is caused by broken stack filtering (and the root cause is an assertion inside org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner rethrowing the original exception.

      I will add a workaround by disabling stack filtering; full stack may be verbose but it is better than a broken stack.


        People

        • Assignee:
          Dawid Weiss
          Reporter:
          Dawid Weiss
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development