Lucene - Core
  1. Lucene - Core
  2. LUCENE-3604

3x/lucene/contrib/CHANGES.txt has two "API Changes" subsections for 3.5.0

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.5
    • Component/s: None
    • Labels:
      None

      Description

      There are two "API Changes" sections which is confusing when looking at the txt version of the file.
      The HTML expands only the first of the two, unless expand-all is clicked.

        Activity

        Doron Cohen created issue -
        Doron Cohen committed 1207018 (1 file)
        Reviews: none

        LUCENE-3604: 3x/lucene/contrib/CHANGES.txt has two "API Changes" subsections for 3.5.0

        Doron Cohen added a comment -

        Fixed the 3x file in r1207018 - ordering the "API Changes" entries by their date (by svn log).
        Keeping open for fixing the Changes.html that already appears in the Web site.

        Doron Cohen added a comment -

        I looked at "HowToUpdateTheWebSite" but still do not understand how to update the contrib/Changes.html that appears in the main Web site.

        Is it a 'versioned' or 'unversioned' that should be changed?

        I think it is the 'versioned' but then I don't understand the instructions in that wiki page: an example with 3.4.1 requires to 'svn co trunk', is this real?

        So better if this is handled by someone who knows his way around this process.

        Doron Cohen made changes -
        Field Original Value New Value
        Assignee Doron Cohen [ doronc ]
        Steve Rowe added a comment -

        Would anybody object to including these changes on the lucene_solr_3_5 branch, then moving the lucene_solr_3_5_0 tag? Uwe fixed another CHANGES.txt issue on the branch, so moving the tag would also include that fix.

        Uwe Schindler added a comment -

        Moving the tag is a bad idea, we should maybe add another TAG named "post_3_5_0_release_docchanges" as we cannot modify the TARGZs anymore on release servers. Once we get 3.5.1 out we can use the branch but update the webpages with the above tag?

        Steve Rowe added a comment -

        we should maybe add another TAG named "post_3_5_0_release_docchanges" [and then] update the webpages with the above tag?

        +1

        Steve Rowe made changes -
        Assignee Steven Rowe [ steve_rowe ]
        sarowe committed 1207561 (4 files)
        Steve Rowe added a comment -

        I merged Doron's changes to the lucene_solr_3_5 branch, then created a new tag: https://svn.apache.org/repos/asf/lucene/dev/tags/post_3_5_0_release_doc_changes. I'll work on updating the Lucene website to be built from this tag.

        Steve Rowe added a comment -

        I ran ant changes-to-html from lucene/ on the tip of the lucene_solr_3_5 branch (same as the new tag), then copied the resulting Changes.html to people.apache.org:/www/lucene.apache.org/java/3_5_0/changes/. The new version will show up on the website once the periodic resync happens.

        Steve Rowe made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Lucene Fields New [ 10121 ]
        Fix Version/s 3.5 [ 12317877 ]
        Resolution Fixed [ 1 ]
        Steve Rowe added a comment -

        Uwe pointed out on #lucene-dev that I also needed to copy over the resulting Contrib-Changes.html - that's where Doron's changes are - to the versioned website. I've done that now.

        Shai Erera added a comment -

        Thanks for taking care of this Steven. I think it will be good to update the Wiki page as well ("HowToUpdateTheWebsite"), because if I read the instructions there, they don't mention running "ant changes-to-html" and/or copy the result to people.apache.org. Did you run "forrest site" (that's what the instructions say)?

        Would you mind updating the Wiki page with the steps that you've done, so that next time we can do it ourselves?

        Doron Cohen added a comment -

        The new version will show up on the website once the periodic resync happens.

        3.5-contrib-changes now shows the correct API changes. Thanks Steven!

        Steve Rowe added a comment - - edited

        Shai,

        I updated both the ReleaseTodo and the HowToUpdateTheWebsite wiki pages to be more explicit about how the versioned website is produced and populated.

        I did not regenerate the Forrest site, nor did I reproduce the javadocs, because the changes were restricted to the CHANGES.txt files.

        The HTML-formatted CHANGES files are produced by ant package, which runs the changes-to-html and javadocs targets and combines their results with the Forrest-generated site under the docs/ directory in the binary release package.

        Shai Erera added a comment -

        Thanks. It's clear now !

        Uwe Schindler made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Steve Rowe
            Reporter:
            Doron Cohen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development