Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-3577

rename expungeDeletes

    XMLWordPrintableJSON

Details

    • Task
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 3.5, 4.0-ALPHA
    • None
    • None
    • New

    Description

      Similar to optimize(), expungeDeletes() has a misleading name.

      We already had problems with this on the user list because TieredMergePolicy
      didn't 'expunge' all their deletes.

      Also I think expunge is the wrong word, because expunge makes it seem
      like you just wrangle up the deletes and kick them out of the party and
      that it should be fast.

      Attachments

        1. LUCENE-3577.patch
          25 kB
          Michael McCandless

        Activity

          People

            mikemccand Michael McCandless
            rcmuir Robert Muir
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: