Lucene - Core
  1. Lucene - Core
  2. LUCENE-2959 [GSoC] Implementing State of the Art Ranking for Lucene
  3. LUCENE-3173

Rename some classes and methods in the search package so their names describe their roles

    Details

    • Type: Sub-task Sub-task
    • Status: Open
    • Priority: Trivial Trivial
    • Resolution: Unresolved
    • Affects Version/s: flexscoring branch
    • Fix Version/s: None
    • Component/s: core/search
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      In an IRC discussion with Robert Muir, it has come up that the names of certain classes and methods in the search package do not describe the role of the class or method in question. Therefore, we propose the following name changes:

      • Scorer to Matcher
      • Similarity.computeWeight() to Similarity.computeStats()
      • Similarity.DocScorer to Similarity.Scorer*

      *: Under consideration.

      The reason for the name computeStats() is that this method will be used by the new Similarity subclasses to compute all the statistics they need, not just idf.

      1. irc.log
        0.7 kB
        David Mark Nemeskey

        Activity

        David Mark Nemeskey created issue -
        Hide
        David Mark Nemeskey added a comment -

        Log of the IRC conversation.

        Show
        David Mark Nemeskey added a comment - Log of the IRC conversation.
        David Mark Nemeskey made changes -
        Field Original Value New Value
        Attachment irc.log [ 12481503 ]
        David Mark Nemeskey made changes -
        Description In an IRC discussion with Robert Muir, it has come up that the names of certain classes and methods in the search package do not describe the role of the class or method in question. Therefore, we propose the following name changes:
        - Scorer to Matcher
        - Similarity.computeWeight() to Similarity.computeStats()
        - Similarity.DocScorer to Similarity.Scorer*

        (*) Under consideration.

        The reason for the name computeStats() is that this method will be used by the new Similarity subclasses to compute all the statistics they need, not just idf.
        In an IRC discussion with Robert Muir, it has come up that the names of certain classes and methods in the search package do not describe the role of the class or method in question. Therefore, we propose the following name changes:
        - Scorer to Matcher
        - Similarity.computeWeight() to Similarity.computeStats()
        - Similarity.DocScorer to Similarity.Scorer*

        *: Under consideration.

        The reason for the name computeStats() is that this method will be used by the new Similarity subclasses to compute all the statistics they need, not just idf.
        David Mark Nemeskey made changes -
        Parent LUCENE-2959 [ 12501006 ]
        Issue Type Improvement [ 4 ] Sub-task [ 7 ]

          People

          • Assignee:
            David Mark Nemeskey
            Reporter:
            David Mark Nemeskey
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:

              Development