Lucene - Core
  1. Lucene - Core
  2. LUCENE-3167

Make lucene/solr a OSGI bundle through Ant

    Details

    • Type: New Feature New Feature
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      bndtools

    • Lucene Fields:
      New

      Description

      We need to make a bundle thriugh Ant, so the binary can be published and no more need the download of the sources. Actually to get a OSGI bundle we need to use maven tools and build the sources. Here the reference for the creation of the OSGI bundle through Maven:

      https://issues.apache.org/jira/browse/LUCENE-1344

      Bndtools could be used inside Ant

      1. lucene_trunk.patch
        6 kB
        Luca Stancapiano
      2. lucene_trunk.patch
        6 kB
        Luca Stancapiano
      3. LUCENE-3167_20130108.patch
        45 kB
        Tommaso Teofili
      4. LUCENE-3167.patch
        46 kB
        Luca Stancapiano
      5. LUCENE-3167.patch
        32 kB
        Steve Rowe
      6. LUCENE-3167.patch
        9 kB
        Luca Stancapiano

        Issue Links

          Activity

          Luca Stancapiano created issue -
          Luca Stancapiano made changes -
          Field Original Value New Value
          Description We need to make a bundle thriugh Ant, so the binary can be published and no more need the download of the sources. Actually to get a OSGI bundle we need to use maven tools and build the sources. Here the reference for the creation of the OSGI bundle through Maven.

          Bndtools could be used inside Ant

          https://issues.apache.org/jira/browse/LUCENE-1344
          We need to make a bundle thriugh Ant, so the binary can be published and no more need the download of the sources. Actually to get a OSGI bundle we need to use maven tools and build the sources. Here the reference for the creation of the OSGI bundle through Maven:

          https://issues.apache.org/jira/browse/LUCENE-1344

          Bndtools could be used inside Ant
          Luca Stancapiano made changes -
          Comment [ Lucene uses the 2.3.4 version of maven-bundle-plugin. So it is better downlaod the 1.15.0 version of bndlib instead of the last. The download url for bndlib 1.15.0 will be:

          http://mirrors.ibiblio.org/pub/mirrors/maven2/biz/aQute/bndlib/1.15.0/bndlib-1.15.0.jar ]
          Luca Stancapiano made changes -
          Attachment lucene_trunk.patch [ 12485598 ]
          Luca Stancapiano made changes -
          Attachment lucene_trunk.patch [ 12489593 ]
          Luca Stancapiano made changes -
          Attachment LUCENE-3167.patch [ 12492526 ]
          Steve Rowe made changes -
          Attachment LUCENE-3406.patch [ 12494242 ]
          Steve Rowe made changes -
          Attachment LUCENE-3406.patch [ 12494242 ]
          Steve Rowe made changes -
          Attachment LUCENE-3167.patch [ 12494243 ]
          Luca Stancapiano made changes -
          Attachment LUCENE-3167.patch [ 12498343 ]
          Gert Vanthienen made changes -
          Link This issue supercedes SMX4-1306 [ SMX4-1306 ]
          Tommaso Teofili made changes -
          Attachment LUCENE-3167_20130108.patch [ 12563756 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Luca Stancapiano
            • Votes:
              13 Vote for this issue
              Watchers:
              17 Start watching this issue

              Dates

              • Created:
                Updated:

                Development