Lucene - Core
  1. Lucene - Core
  2. LUCENE-2685

Test failure: contrib/xml-query-parser: TestQueryTemplateManager.testFormTransforms()

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: None
    • Component/s: modules/other
    • Labels:
      None
    • Environment:

      Windows Vista 64-bit, Sun JDK 1.5.0_13 64-bit

    • Lucene Fields:
      New

      Description

      [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 3.031 sec
      [junit]
      [junit] ------------- Standard Output ---------------
      [junit] NOTE: reproduce with: ant test -Dtestcase=TestQueryTemplateManager -Dtestmethod=testFormTransforms -Dtests.seed=-3178590569335578120:-7726718235997875276
      [junit] NOTE: test params are: codec=SimpleText, locale=tr_TR, timezone=America/Rainy_River
      [junit] ------------- ---------------- ---------------
      [junit] ------------- Standard Error -----------------
      [junit] java.lang.RuntimeException: Instruction unknown: load?nstruction
      [junit] at com.sun.org.apache.bcel.internal.util.InstructionFinder.mapName(InstructionFinder.java:138)
      [junit] at com.sun.org.apache.bcel.internal.util.InstructionFinder.compilePattern(InstructionFinder.java:170)
      [junit] at com.sun.org.apache.bcel.internal.util.InstructionFinder.search(InstructionFinder.java:218)
      [junit] at com.sun.org.apache.bcel.internal.util.InstructionFinder.search(InstructionFinder.java:264)
      [junit] at com.sun.org.apache.xalan.internal.xsltc.compiler.Mode.peepHoleOptimization(Mode.java:1444)
      [junit] at com.sun.org.apache.xalan.internal.xsltc.compiler.Mode.compileApplyTemplates(Mode.java:1058)
      [junit] at com.sun.org.apache.xalan.internal.xsltc.compiler.Stylesheet.compileModes(Stylesheet.java:615)
      [junit] at com.sun.org.apache.xalan.internal.xsltc.compiler.Stylesheet.translate(Stylesheet.java:730)
      [junit] at com.sun.org.apache.xalan.internal.xsltc.compiler.XSLTC.compile(XSLTC.java:354)
      [junit] at com.sun.org.apache.xalan.internal.xsltc.compiler.XSLTC.compile(XSLTC.java:429)
      [junit] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerFactoryImpl.newTemplates(TransformerFactoryImpl.java:797)
      [junit] at org.apache.lucene.xmlparser.QueryTemplateManager.getTemplates(QueryTemplateManager.java:208)
      [junit] at org.apache.lucene.xmlparser.QueryTemplateManager.addQueryTemplate(QueryTemplateManager.java:75)
      [junit] at org.apache.lucene.xmlparser.TestQueryTemplateManager.testFormTransforms(TestQueryTemplateManager.java:74)
      ...
      [junit] ERROR: 'Instruction unknown: load?nstruction'
      [junit] FATAL ERROR: 'Could not compile stylesheet'

        Issue Links

          Activity

          Robert Muir added a comment -

          The bug is specific to Sun's java 5 JRE. (i installed 1.5.0_22 and it still fails).

          Its no problem on apache harmony java 5 or sun java 6...

          Robert Muir added a comment -

          Here's a patch adding an assumeTrue() for the broken sun jre versions,
          since they are all affected by http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6240963

          Uwe Schindler added a comment -

          Very old bug, well known for the bytecode policeman

          We cannot do anything against that, only disable the test. Stupid default locale for toLowerCase(). Sun should deprecate all methods assuming default locales or charsets.

          Robert Muir added a comment -

          I agree, bad that the bug originated from apache code code though

          I will commit the assumeTrue to 3.x and trunk shortly

          Robert Muir added a comment -

          I committed the test workaround to trunk/3x (revisions 1004241, 1004244).

          Uwe, maybe you can add some user workarounds to contrib/CHANGES.txt ?

          Furkan KAMACI added a comment -

          This issue is similar to that one: https://issues.apache.org/jira/browse/SOLR-2271 and can be labeled as Fixed as like that issue.

          Uwe Schindler added a comment -

          This is fixed since LUCENE 4.0, because Lucene 4 is on Java 6, which has no longer a broken XALAN variant


            People

            • Assignee:
              Unassigned
              Reporter:
              Steve Rowe
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development