Lucene - Core
  1. Lucene - Core
  2. LUCENE-2191

rename Tokenizer.reset(Reader) to Tokenizer.setReader(Reader)

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0-BETA, Trunk
    • Component/s: modules/analysis
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      in TokenStream there is a reset() method, but the method in Tokenizer used to set a new Reader is called reset(Reader).

      in my opinion this name overloading creates a lot of confusion, and we see things like reset(Reader) calling reset() even in StandardTokenizer...

      So I think this would be some work to fulfill all the backwards compatibility, but worth it because when you look at the existing reset(Reader) and reset() code in various tokenizers, or the javadocs for Tokenizer, its pretty confusing and inconsistent.

      1. LUCENE-2191.patch
        23 kB
        Robert Muir
      2. LUCENE-2191.patch
        25 kB
        Robert Muir

        Issue Links

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Robert Muir
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development