Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-2101

Default Stopwords should use specific Version in CharArraySet construtor

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 4.9, 6.0
    • Component/s: modules/analysis
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      LUCENE-2094 added a version to the constructor of CharArraySet. The default sets in *Analyzer uses Version.LUCENE_CURRENT which currently does not do any harm. Yet, in the future changes to CharArraySet depending on the version could potentially cause index corruption if those default version are not changed. To make sure such a corruption can not happen the default sets should use a specific Version (Version.LUCENE_31)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                simonw Simon Willnauer
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated: