Lucene - Core
  1. Lucene - Core
  2. LUCENE-1890

auto-warming from Apache Solr causes NULL Pointer

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.4.1
    • Fix Version/s: 4.4
    • Component/s: modules/spatial
    • Labels:
    • Environment:

      Linux

    • Lucene Fields:
      New

      Description

      Sep 6, 2009 12:48:07 PM org.apache.solr.common.SolrException log
      SEVERE: Error during auto-warming of key:org.apache.solr.search.QueryResultKey@b00371eb:java.lang.NullPointerException
      at org.apache.lucene.spatial.tier.DistanceFieldComparatorSource$DistanceScoreDocLookupComparator.copy(DistanceFieldComparatorSource.java:101)
      at org.apache.lucene.search.TopFieldCollector$MultiComparatorScoringMaxScoreCollector.collect(TopFieldCollector.java:554)
      at org.apache.solr.search.DocSetDelegateCollector.collect(DocSetHitCollector.java:98)
      at org.apache.lucene.search.IndexSearcher.doSearch(IndexSearcher.java:281)
      at org.apache.lucene.search.IndexSearcher.search(IndexSearcher.java:253)
      at org.apache.lucene.search.Searcher.search(Searcher.java:171)
      at org.apache.solr.search.SolrIndexSearcher.getDocListAndSetNC(SolrIndexSearcher.java:1088)
      at org.apache.solr.search.SolrIndexSearcher.getDocListC(SolrIndexSearcher.java:876)
      at org.apache.solr.search.SolrIndexSearcher.access$000(SolrIndexSearcher.java:53)
      at org.apache.solr.search.SolrIndexSearcher$3.regenerateItem(SolrIndexSearcher.java:328)
      at org.apache.solr.search.LRUCache.warm(LRUCache.java:194)
      at org.apache.solr.search.SolrIndexSearcher.warm(SolrIndexSearcher.java:1468)
      at org.apache.solr.core.SolrCore$3.call(SolrCore.java:1142)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)

      1. lucene-spatial-2.9-dev.jar
        58 kB
        Bill Bell
      2. localsolr.jar
        27 kB
        Bill Bell

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        1344d 7h 53m 1 Greg Bowyer 13/May/13 04:32
        Greg Bowyer made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Greg Bowyer [ gbowyer@fastmail.co.uk ]
        Resolution Cannot Reproduce [ 5 ]
        Greg Bowyer added a comment -

        I am going to be bold and make the assumption that, since spatial has been re-worked and Lucene has gone from 2.x -> 4.x this issue is no longer present.

        Greg Bowyer made changes -
        Labels dead
        Uwe Schindler made changes -
        Fix Version/s 4.4 [ 12324323 ]
        Fix Version/s 4.3 [ 12324143 ]
        Robert Muir made changes -
        Fix Version/s 4.3 [ 12324143 ]
        Fix Version/s 5.0 [ 12321663 ]
        Fix Version/s 4.2 [ 12323899 ]
        Mark Miller made changes -
        Fix Version/s 4.2 [ 12323899 ]
        Fix Version/s 4.1 [ 12321140 ]
        Mark Miller made changes -
        Fix Version/s 5.0 [ 12321663 ]
        Robert Muir made changes -
        Fix Version/s 4.1 [ 12321140 ]
        Fix Version/s 4.0 [ 12314025 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12562718 ] jira [ 12583647 ]
        Mark Thomas made changes -
        Workflow jira [ 12475089 ] Default workflow, editable Closed status [ 12562718 ]
        Bill Bell added a comment - - edited

        Url for the solr.war: http://ams.kaango.com.s3.amazonaws.com/solr.war

        SEVERE: Error during auto-warming of key:org.apache.solr.search.QueryResultKey@b9e3312a:java.lang.NullPointerException

        Sep 9, 2009 12:00:08 AM org.apache.solr.common.SolrException log
        SEVERE: Error during auto-warming of key:org.apache.solr.search.QueryResultKey@9d1b3222:java.lang.NullPointerException

        Sep 9, 2009 12:00:08 AM org.apache.solr.common.SolrException log
        SEVERE: Error during auto-warming of key:org.apache.solr.search.QueryResultKey@58d1adf1:java.lang.NullPointerException

        Sep 9, 2009 12:00:09 AM org.apache.solr.common.SolrException log
        SEVERE: Error during auto-warming of key:org.apache.solr.search.QueryResultKey@26a73b9b:java.lang.NullPointerException

        Sep 9, 2009 12:00:09 AM org.apache.solr.common.SolrException log
        SEVERE: Error during auto-warming of key:org.apache.solr.search.QueryResultKey@e2d600b1:java.lang.NullPointerException

        Bill Bell made changes -
        Attachment localsolr.jar [ 12419025 ]
        Attachment lucene-spatial-2.9-dev.jar [ 12419026 ]
        Bill Bell added a comment -

        SOLR WAR

        Bill Bell added a comment -

        I get several of these errors. I am using SOLR with LOCAL LUCENE. It is a version from a few months back. I am including solr.war and the local solr in the hope that it might help debug the issue. I tried to run the latest SOLR and LOCAL SOLR, but I am unable to get it to work without several errors.

        Here is the output from /system:
        <response>

        <lst name="responseHeader">
        <int name="status">0</int>
        <int name="QTime">117</int>
        </lst>

        <lst name="core">
        <str name="schema">kaango-0.9.0</str>
        <str name="host">domU-12-31-39-03-78-41.compute-1.internal</str>
        <date name="now">2009-09-09T07:26:18.959Z</date>
        <date name="start">2009-09-07T07:22:13.146Z</date>

        <lst name="directory">
        <str name="instance">/vol/solr/core0</str>
        <str name="data">/vol/solr/core0/data</str>
        <str name="index">/mnt/solr/core0/data/index</str>
        </lst>
        </lst>

        <lst name="lucene">
        <str name="solr-spec-version">1.3.0.2009.06.01.20.24.48</str>
        <str name="solr-impl-version">1.4-dev exported - tomcat - 2009-06-01 20:24:48</str>
        <str name="lucene-spec-version">2.9-dev</str>
        <str name="lucene-impl-version">2.9-dev 779312 - 2009-05-27 17:19:55</str>
        </lst>

        <lst name="jvm">
        <str name="version">10.0-b19</str>
        <str name="name">Java HotSpot(TM) 64-Bit Server VM</str>
        <int name="processors">2</int>

        <lst name="memory">
        <str name="free">4 GB</str>
        <str name="total">6 GB</str>
        <str name="max">6 GB</str>
        <str name="used">1 GB (%23)</str>
        </lst>

        <lst name="jmx">

        <str name="bootclasspath">
        /usr/java/jdk1.6.0_04/jre/lib/resources.jar:/usr/java/jdk1.6.0_04/jre/lib/rt.jar:/usr/java/jdk1.6.0_04/jre/lib/sunrsasign.jar:/usr/java/jdk1.6.0_04/jre/lib/jsse.jar:/usr/java/jdk1.6.0_04/jre/lib/jce.jar:/usr/java/jdk1.6.0_04/jre/lib/charsets.jar:/usr/java/jdk1.6.0_04/jre/classes
        </str>
        <str name="classpath">:/vol/tomcat/bin/bootstrap.jar</str>

        <arr name="commandLineArgs">
        <str>-Xmx6500m</str>
        <str>-Xms6500m</str>
        <str>-Djava.awt.headless=true</str>
        <str>-Dsolr.solr.home=/vol/solr/</str>

        <str>
        -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
        </str>

        <str>
        -Djava.util.logging.config.file=/vol/tomcat/conf/logging.properties
        </str>
        <str>-Djava.endorsed.dirs=/vol/tomcat/endorsed</str>
        <str>-Dcatalina.base=/vol/tomcat</str>
        <str>-Dcatalina.home=/vol/tomcat</str>
        <str>-Djava.io.tmpdir=/vol/tomcat/temp</str>
        </arr>
        <date name="startTime">2009-09-07T07:22:10.29Z</date>
        <long name="upTimeMS">173048669</long>
        </lst>
        </lst>

        <lst name="system">
        <str name="name">Linux</str>
        <str name="version">2.6.21.7-2.fc8xen</str>
        <str name="arch">amd64</str>
        <double name="systemLoadAverage">0.3</double>
        <str name="uname">(error executing: uname -a)</str>
        <str name="ulimit">(error executing: ulimit -n)</str>
        <str name="uptime">(error executing: uptime)</str>
        </lst>
        </response>

        Mark Miller made changes -
        Field Original Value New Value
        Fix Version/s 3.1 [ 12314025 ]
        Fix Version/s 2.4.1 [ 12313516 ]
        Mark Miller added a comment -

        it looks like the distanceFilter is getting set to null - clear could do that, but I don't see anywhere it would be called ... not sure what Solr code you using though - just checked one of the later patches in JIRA. From the Lucene end, I don't see how you could get a null there unless you inited your DistanceFieldComparatorSource with a null filter.

        Bill Bell created issue -

          People

          • Assignee:
            Greg Bowyer
            Reporter:
            Bill Bell
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development