My reason for this, is that this change will make it more difficult for users
that want to use several implementations of diff parsers at same time.
Well... simple things should be simple; complex things should be
I expect the vast majority of Lucene users will use the standard
QueryParser, as is. We should make things as simple as possible for
Then, more advanced users will absolutely love the modularity of this
new QueryParser and cherry pick the parts they want to build up their
own parsing chain. Things need not be simple for such users; just
I don't like the idea of "stripped Standard prefix" or "StandardQueryParserHelper to simply QueryParser".
OK I do agree naming conflicts are a real hassle, and keeping this
prefix doesn't harm the "simple" case...
So I'll put back the prefixes to the Standard* classes, move the
'original' package to 'standard'. So it'll be StandardQueryParser and
the simple usage is like this:
StandardQueryParser parser = new StandardQueryParser(analyzer);
Query q = parser.parse("a OR b OR c", "field");
I think I forgot to add a readme.txt to that folder describing how to build the OriginalQueryParser.jj.
Can you please add that as part of this patch with the text in the comment above, If you are busy
let know I can submit another patch with that.
OK will do.