Lucene - Core
  1. Lucene - Core
  2. LUCENE-1631

CLONE -You cannot sort on fields that don't exist

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.4.1
    • Fix Version/s: 1.9
    • Component/s: core/search
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: Other

      Description

      I still get this error in 2.4.1 - if field does not exist in index, there is nullPointException if it search over multiple index. In following test code, there is runtime error, here is part of test code.

      indexSingleFieldDocs(new Field[]

      {new Field("ds", "xyz", Field.Store.YES, Field.Index.NOT_ANALYZED) , new Field("dsc", "hello", Field.Store.NO, Field.Index.ANALYZED)}

      );
      indexSingleFieldDocs(new Field[]

      {new Field("ds", "def", Field.Store.YES, Field.Index.NOT_ANALYZED) , new Field("dsc", "hello", Field.Store.NO, Field.Index.ANALYZED)}

      );

      ...

      QueryParser p = new QueryParser("dsc", new StandardAnalyzer());
      Query q = p.parse("hello");
      Hits hits = searcher.search(q,new Sort("ds"));

      If change "ds" to some others, got this exception:
      java.lang.RuntimeException: field "ds" does not appear to be indexed
      at org.apache.lucene.search.ExtendedFieldCacheImpl$5.createValue(ExtendedFieldCacheImpl.java:173)
      at org.apache.lucene.search.FieldCacheImpl$Cache.get(FieldCacheImpl.java:71)
      at org.apache.lucene.search.ExtendedFieldCacheImpl.getAuto(ExtendedFieldCacheImpl.java:127)
      at org.apache.lucene.search.FieldSortedHitQueue.comparatorAuto(FieldSortedHitQueue.java:487)
      at org.apache.lucene.search.FieldSortedHitQueue$1.createValue(FieldSortedHitQueue.java:184)
      at org.apache.lucene.search.FieldCacheImpl$Cache.get(FieldCacheImpl.java:71)
      at org.apache.lucene.search.FieldSortedHitQueue.getCachedComparator(FieldSortedHitQueue.java:167)
      at org.apache.lucene.search.FieldSortedHitQueue.<init>(FieldSortedHitQueue.java:55)
      at org.apache.lucene.search.TopFieldDocCollector.<init>(TopFieldDocCollector.java:43)
      at org.apache.lucene.search.IndexSearcher.search(IndexSearcher.java:121)
      at org.apache.lucene.search.Hits.getMoreDocs(Hits.java:113)
      at org.apache.lucene.search.Hits.<init>(Hits.java:90)
      at org.apache.lucene.search.Searcher.search(Searcher.java:61)
      at com.edgenius.test.lucene.TestLucene.testSort(TestLucene.java:207)

        Issue Links

          Activity

          steve neo created issue -
          steve neo made changes -
          Field Original Value New Value
          Link This issue is a clone of LUCENE-374 [ LUCENE-374 ]
          steve neo made changes -
          Link This issue is related to LUCENE-916 [ LUCENE-916 ]
          steve neo made changes -
          Affects Version/s 2.4.1 [ 12313516 ]
          Description While it's possible to search for fields that don't exist (you'll get 0 hits),
          you'll get an exception if you try to sort by a field that has no values. The
          exception is this:
            
          if (termEnum.term() == null) {
            throw new RuntimeException ("no terms in field " + field);
          }
            
          I'll attach a change suggested by Yonik Seeley that removes this exception.
           
          Also, the if-condition above is incomplete anyway, so currently the exception
          is not always thrown (as termEnum .term() might well be != null but point to a
          term in a different field already)
          I still get this error in 2.4.1 - if field does not exist in index, there is nullPointException if it search over multiple index. In following test code, there is runtime error, here is part of test code.


          indexSingleFieldDocs(new Field[]{new Field("ds", "xyz", Field.Store.YES, Field.Index.NOT_ANALYZED)
          , new Field("dsc", "hello", Field.Store.NO, Field.Index.ANALYZED)});
          indexSingleFieldDocs(new Field[]{new Field("ds", "def", Field.Store.YES, Field.Index.NOT_ANALYZED)
          , new Field("dsc", "hello", Field.Store.NO, Field.Index.ANALYZED)});

          ...

          QueryParser p = new QueryParser("dsc", new StandardAnalyzer());
          Query q = p.parse("hello");
          Hits hits = searcher.search(q,new Sort("ds"));


          If change "ds" to some others, got this exception:
          java.lang.RuntimeException: field "ds" does not appear to be indexed
          at org.apache.lucene.search.ExtendedFieldCacheImpl$5.createValue(ExtendedFieldCacheImpl.java:173)
          at org.apache.lucene.search.FieldCacheImpl$Cache.get(FieldCacheImpl.java:71)
          at org.apache.lucene.search.ExtendedFieldCacheImpl.getAuto(ExtendedFieldCacheImpl.java:127)
          at org.apache.lucene.search.FieldSortedHitQueue.comparatorAuto(FieldSortedHitQueue.java:487)
          at org.apache.lucene.search.FieldSortedHitQueue$1.createValue(FieldSortedHitQueue.java:184)
          at org.apache.lucene.search.FieldCacheImpl$Cache.get(FieldCacheImpl.java:71)
          at org.apache.lucene.search.FieldSortedHitQueue.getCachedComparator(FieldSortedHitQueue.java:167)
          at org.apache.lucene.search.FieldSortedHitQueue.<init>(FieldSortedHitQueue.java:55)
          at org.apache.lucene.search.TopFieldDocCollector.<init>(TopFieldDocCollector.java:43)
          at org.apache.lucene.search.IndexSearcher.search(IndexSearcher.java:121)
          at org.apache.lucene.search.Hits.getMoreDocs(Hits.java:113)
          at org.apache.lucene.search.Hits.<init>(Hits.java:90)
          at org.apache.lucene.search.Searcher.search(Searcher.java:61)
          at com.edgenius.test.lucene.TestLucene.testSort(TestLucene.java:207)
          steve neo added a comment -

          In my real project, I am using over multiple indexes, I got this error:

          Exception in thread "MultiSearcher thread #6" java.lang.RuntimeException: field "docType" does not appear to be indexed
          at org.apache.lucene.search.ExtendedFieldCacheImpl$5.createValue(ExtendedFieldCacheImpl.java:173)
          at org.apache.lucene.search.FieldCacheImpl$Cache.get(FieldCacheImpl.java:71)
          at org.apache.lucene.search.ExtendedFieldCacheImpl.getAuto(ExtendedFieldCacheImpl.java:127)
          at org.apache.lucene.search.FieldSortedHitQueue.comparatorAuto(FieldSortedHitQueue.java:487)
          at org.apache.lucene.search.FieldSortedHitQueue$1.createValue(FieldSortedHitQueue.java:184)
          at org.apache.lucene.search.FieldCacheImpl$Cache.get(FieldCacheImpl.java:71)
          at org.apache.lucene.search.FieldSortedHitQueue.getCachedComparator(FieldSortedHitQueue.java:167)
          at org.apache.lucene.search.FieldSortedHitQueue.<init>(FieldSortedHitQueue.java:55)
          at org.apache.lucene.search.TopFieldDocCollector.<init>(TopFieldDocCollector.java:43)
          at org.apache.lucene.search.IndexSearcher.search(IndexSearcher.java:121)
          at org.apache.lucene.search.MultiSearcherThread.run(ParallelMultiSearcher.java:250)
          2009-05-09 01:26:41,305 ERROR [SearchServiceImpl] Search failed
          org.springmodules.lucene.search.LuceneSearchException: Error during searching; nested exception is java.lang.NullPointerException
          at org.springmodules.lucene.search.core.DefaultLuceneSearchTemplate.search(DefaultLuceneSearchTemplate.java:292)
          at com.edgenius.wiki.search.service.AbstractSearchService.commonSearch(AbstractSearchService.java:84)
          at com.edgenius.wiki.search.service.SearchServiceImpl.search(SearchServiceImpl.java:36)
          at com.edgenius.wiki.gwt.server.SearchControllerImpl.search(SearchControllerImpl.java:81)
          at sun.reflect.GeneratedMethodAccessor136.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:585)
          at com.edgenius.wiki.gwt.server.handler.GWTSpringController.processCall(GWTSpringController.java:93)
          at com.google.gwt.user.server.rpc.RemoteServiceServlet.doPost(RemoteServiceServlet.java:86)
          at com.edgenius.wiki.gwt.server.handler.GWTSpringController.handleRequest(GWTSpringController.java:179)
          at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:48)
          at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:875)
          at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:809)
          at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:571)
          at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:511)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at com.edgenius.core.webapp.filter.AjaxRedirectFilter.doFilterInternal(AjaxRedirectFilter.java:46)
          at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at com.edgenius.core.webapp.filter.SEFilter.doFilterInternal(SEFilter.java:63)
          at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:378)
          at org.springframework.security.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:109)
          at org.springframework.security.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:83)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
          at org.springframework.security.ui.ExceptionTranslationFilter.doFilterHttp(ExceptionTranslationFilter.java:101)
          at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
          at org.springframework.security.providers.anonymous.AnonymousProcessingFilter.doFilterHttp(AnonymousProcessingFilter.java:105)
          at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
          at org.springframework.security.ui.rememberme.RememberMeProcessingFilter.doFilterHttp(RememberMeProcessingFilter.java:116)
          at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
          at org.springframework.security.wrapper.SecurityContextHolderAwareRequestFilter.doFilterHttp(SecurityContextHolderAwareRequestFilter.java:91)
          at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
          at org.springframework.security.ui.AbstractProcessingFilter.doFilterHttp(AbstractProcessingFilter.java:277)
          at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
          at org.springframework.security.ui.logout.LogoutFilter.doFilterHttp(LogoutFilter.java:89)
          at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
          at com.edgenius.wiki.security.acegi.CaptchaValidationProcessingFilter.doFilter(CaptchaValidationProcessingFilter.java:76)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
          at org.springframework.security.context.HttpSessionContextIntegrationFilter.doFilterHttp(HttpSessionContextIntegrationFilter.java:235)
          at org.springframework.security.ui.SpringSecurityFilter.doFilter(SpringSecurityFilter.java:53)
          at org.springframework.security.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:390)
          at org.springframework.security.util.FilterChainProxy.doFilter(FilterChainProxy.java:175)
          at org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:236)
          at org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:167)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.springframework.orm.hibernate3.support.OpenSessionInViewFilter.doFilterInternal(OpenSessionInViewFilter.java:198)
          at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at com.edgenius.wiki.webapp.filter.InstallFilter.doFilterInternal(InstallFilter.java:49)
          at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
          at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
          at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
          at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
          at java.lang.Thread.run(Thread.java:613)
          Caused by: java.lang.NullPointerException
          at org.apache.lucene.search.MultiSearcherThread.hits(ParallelMultiSearcher.java:280)
          at org.apache.lucene.search.ParallelMultiSearcher.search(ParallelMultiSearcher.java:136)
          at org.apache.lucene.search.Hits.getMoreDocs(Hits.java:113)
          at org.apache.lucene.search.Hits.<init>(Hits.java:90)
          at org.apache.lucene.search.Searcher.search(Searcher.java:72)
          at org.springmodules.lucene.search.factory.SimpleLuceneSearcher.search(SimpleLuceneSearcher.java:91)
          at com.edgenius.wiki.search.service.AbstractSearchService$1.doWithSearcher(AbstractSearchService.java:92)
          at org.springmodules.lucene.search.core.DefaultLuceneSearchTemplate.search(DefaultLuceneSearchTemplate.java:288)
          ... 76 more

          Yonik Seeley added a comment -

          This is only for the AUTO sort field type (when you don't specify how to sort the field).
          In your application, can you use the SortField constructors that take a type argument?

          Michael McCandless added a comment -

          Is this a dup of LUCENE-916?

          Michael McCandless added a comment -

          We are removing SortField.AUTO in 3.0.

          Michael McCandless made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Michael McCandless made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Michael McCandless added a comment -

          I meant to resolve as Won't Fix.

          Michael McCandless made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Won't Fix [ 2 ]
          Mark Thomas made changes -
          Workflow jira [ 12462936 ] Default workflow, editable Closed status [ 12563283 ]
          Mark Thomas made changes -
          Workflow Default workflow, editable Closed status [ 12563283 ] jira [ 12584389 ]
          Uwe Schindler made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          25d 4h 22m 1 Michael McCandless 02/Jun/09 19:41
          Resolved Resolved Reopened Reopened
          7m 17s 1 Michael McCandless 02/Jun/09 19:48
          Reopened Reopened Resolved Resolved
          16s 1 Michael McCandless 02/Jun/09 19:49
          Resolved Resolved Closed Closed
          1437d 14h 55m 1 Uwe Schindler 10/May/13 10:44

            People

            • Assignee:
              Yonik Seeley
              Reporter:
              steve neo
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development