Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-1366

Rename Field.Index.UN_TOKENIZED/TOKENIZED/NO_NORMS

Agile BoardAttach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9, 2.0.0, 2.1, 2.2, 2.3, 2.3.1, 2.3.2
    • Fix Version/s: 2.4
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      There is confusion about these current Field options and I think we
      should rename them, deprecating the old names in 2.4/2.9 and removing
      them in 3.0. How about this:

      TOKENIZED --> ANALYZED
      UN_TOKENIZED --> NOT_ANALYZED
      NO_NORMS --> NOT_ANALYZED_NO_NORMS
      

      Should we also add ANALYZED_NO_NORMS?

      Spinoff from here:

      http://mail-archives.apache.org/mod_mbox/lucene-java-user/200808.mbox/%3C48a3076a.2679420a.1c53.ffffa5c4%40mx.google.com%3E

        Attachments

        1. LUCENE-1366.patch
          4 kB
          Michael McCandless
        2. LUCENE-1366.patch
          226 kB
          Michael McCandless

        Issue Links

          Activity

            People

            • Assignee:
              mikemccand Michael McCandless
              Reporter:
              mikemccand Michael McCandless

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment