Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: general/website
    • Labels:
      None
    • Lucene Fields:
      Patch Available

      Description

      Some improvements to the Changes.html generated by the changes2html.pl script via the 'changes-to-html' ant task:

      1. Simplified the Simple stylesheet (removed monospace font specification) and made it the default. The Fancy stylesheet is really hard for me to look at (yellow text on light blue background may provide high contrast with low eye strain, but IMHO it's ugly).
      2. Moved the monospace style from the Simple stylesheet to a new stylesheet named "Fixed Width"
      3. Fixed syntax errors in the Fancy stylesheet, so that it displays as intended.
      4. Added <span style="attrib"> to change attributions.
      5. In the Fancy and Simple stylesheets, change attributions are colored dark green.
      6. Now properly handling change attributions in CHANGES.txt that have trailing periods.
      7. Clicking on an anchor to expand its children now changes the document location to show the children.
      8. Hovering over anchors now causes a tooltip to be displayed - either "Click to expand" or "Click to collapse" - the tooltip changes appropriately after a collapse or expansion.
      1. LUCENE-1256.patch
        9 kB
        Steve Rowe
      2. LUCENE-1256.patch
        9 kB
        Steve Rowe
      3. LUCENE-1256.patch
        10 kB
        Steve Rowe
      4. LUCENE-1256.patch
        13 kB
        Steve Rowe
      5. LUCENE-1256.patch
        12 kB
        Doron Cohen
      6. LUCENE-1256.patch
        13 kB
        Steve Rowe

        Issue Links

          Activity

          Steve Rowe added a comment -

          Patch implementing above-described changes.

          Steve Rowe added a comment -

          The issue that introduced generation of Changes.html

          Steve Rowe added a comment -

          Since the Lucene Bugzilla bugs mentioned in CHANGES.txt are no longer present in the Apache Bugzilla database, it doesn't make sense to auto-linkify these any longer.

          Instead, this version of the patch links from each mentioned Bugzilla bug number to the JIRA issue that was cloned from it, and includes the JIRA issue name. For example, the following text:

          ArrayIndexOutOfBoundsExceptions (patch #9110);

          becomes:

          ArrayIndexOutOfBoundsExceptions (patch #9110 [LUCENE-35]);

          Doron Cohen added a comment -

          I didn't try it but from the description it sounds great.
          I'll try it over the weekend.
          For the fancy stylesheet - I put those colors but no sentiments for them here - please feel free to modify them to your taste..

          Steve Rowe added a comment -

          One last bugfix: item #3.1 under 2.3.0's "New features" section is intended to be understood as a component of item #3. This version of the patch renumbers this item to #4, like all previous versions, but it no longer includes a '1' at the beginning of the item's text, as all previous versions did.

          Should hierarchical change item formatting be supported? AFAICT, the above-described item #3.1 is the only occurrence of this phenomenon currently in CHANGES.txt.

          Steve Rowe added a comment -

          One last feature: added "Expand All" and "Collapse All" buttons at the top of the page.

          These buttons are added via Javascript, so they don't appear when Javascript disabled and everything is always expanded.

          This version also cleans up some mis-identified change attributions, e.g. "(see #3 above)".

          Doron Cohen added a comment -

          Patch looks great!
          One minor issue the dynamically inserted buttons do not work on IE 6 for me.
          I changed that to create them in the static HTML lines and now it works in both IE and FF.
          Also modified the colors of the fancy style to be more pleasant and made it default again - for visible separation between the three parts (trunk, last release, older releases).
          Attaching the update - will commit soon.
          Doron

          Steve Rowe added a comment - - edited

          Hi Doron, I like the Fancy stylesheet now - thanks. Attaching a new patch that contains a couple of small changes from your version:

          1. I found a way to fix the bad IE6 behavior with the dynamic Expand All/Collapse All buttons, so I removed your static <input> tags and put the button creation back in the <head><SCRIPT> tag. I prefer this way, because the buttons will not appear at all if javascript is disabled.
          2. Removed an extra copy of styles in ChangesFixedWidthStyle.css
          3. Removed the alternative stylesheets <link> to the Fancy stylesheet (not necessary since it's the default stylesheet)
          Doron Cohen added a comment -

          I just realized that adding the buttons statically means they are shown also when javascript is disabled and then they do nothing.
          I would like to have both - buttons that work also in IE6 and view that is consistent also with javascript disabled.
          If this is not possible I think it is more important for IE6 to work properly. Steven?

          Doron Cohen added a comment -

          cool, thanks, that was fast!

          Steve Rowe added a comment -

          I just realized that I didn't save the editor buffer where I removed the extra styles from ChangesFixedWidthStyle.css – somehow, there are three copies of each style in there. Not attaching (yet another) patch - can you manually remove the extras, Doron?

          Doron Cohen added a comment -

          Actually there are now 3 duplicates in ChangesFixedWidthStyle.css - never mind I'll remove that.
          Yes now without the setAttribute() it works for me too in IE6 as well.
          So I am committing this.

          Doron Cohen added a comment - - edited

          Second time in a row(e) that I am too slow for your fast response...

          Steve Rowe added a comment -

          One tiny display issue I noticed: the Bugzilla issue autolinkification places the </a> tag before the closing right square bracket (']') around the LUCENE-XXXX issue, so the closing bracket is not part of the link text, but it should be.

          This occurs on line #389 on changes2html.pl:

             . qq!$issue&nbsp;[LUCENE-$jira_issue_num</a>]!
          

          should be

             . qq!$issue&nbsp;[LUCENE-$jira_issue_num]</a>!
          

          Again, not including another patch - would you mind fixing this for me, Doron?

          Doron Cohen added a comment -

          sure np

          Doron Cohen added a comment -

          Committed, Thanks Steve!


            People

            • Assignee:
              Doron Cohen
              Reporter:
              Steve Rowe
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development