Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3
    • Component/s: modules/other
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      GData doesn't seem to be maintained anymore. We're going to remove it before we cut the 2.3 release unless there are negative votes.

      In case someones jumps in in the future and starts to maintain it, we can re-add it to the trunk.

      If anyone is using GData and needs it to be in 2.3 please let us know soon!

      1. lucene-1055.patch
        5 kB
        Michael Busch

        Activity

        Michael Busch created issue -
        Yonik Seeley added a comment -

        +1, it will still be in SVN for reference if anyone needs it.

        Simon Willnauer added a comment -

        +1 I don't have the resources to maintain the gdata source code.

        Grant Ingersoll added a comment -

        Let's do an informal survey on the user mailing list first and see if there is any interest (and maybe someone willing to take it on.)

        I will write it up.

        Michael Busch added a comment -

        I will write it up.

        Cool, thanks Grant.

        Michael Busch added a comment -

        This patch should remove everything that belongs to gdata.

        Michael Busch made changes -
        Field Original Value New Value
        Attachment lucene-1055.patch [ 12369569 ]
        Michael Busch added a comment -

        So far one user said on java-user that they would like to use gdata.
        But I think we should remove it anyway from trunk? There's currently
        nobody who can maintain the code and it didn't change at all since
        we released 2.2. So people who want to use it can take the jar from
        the 2.2 release?

        Michael Busch added a comment -

        I'm going to commit this patch and remove Gdata later today if nobody objects.

        buschmi committed 596501 (448 files)
        Reviews: none

        LUCENE-1055: Remove gdata from trunk.

        Lucene trunk
        Michael Busch added a comment -

        Patch committed and gdata removed.

        Michael Busch made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Paul Elschot added a comment -

        After svn update, contrib/gdata-server is still in my working copy.
        Is that intended, or is there still an svn delete to be done?

        Michael Busch added a comment -

        After svn update, contrib/gdata-server is still in my working copy.
        Is that intended, or is there still an svn delete to be done?

        Hmm that's strange. I tried svn up on a different checkout folder and
        contrib/gdata-server was successfully removed. Are you sure that you
        don't have any local changes in that folder that prevent it from being
        removed?

        Hoss Man added a comment -

        contrib/gdata-server is recorded as deleted (so an "svn status" will show that subversion doesn't know anything about it) but if you've ever build gdata-server, then it contains an "ext-libs" directory which was not managed by subversion, so "svn update" won't delete it automatically.

        Paul Elschot added a comment -

        Hoss,
        That must have been the cause. After removing the gdata-server directory manually everything is in order. Thanks.

        Michael Busch made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Mark Thomas made changes -
        Workflow jira [ 12417177 ] Default workflow, editable Closed status [ 12562707 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12562707 ] jira [ 12583637 ]

          People

          • Assignee:
            Michael Busch
            Reporter:
            Michael Busch
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development