Commons Logging
  1. Commons Logging
  2. LOGGING-142

Log4JLogger uses deprecated static members of Priority such as INFO

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.1
    • Fix Version/s: 1.1.2
    • Labels:
      None

      Description

      In version 1.1.1, Log4JLogger uses deprecated static members of Priority such as INFO to construct LoggingEvent. In version 1.0.4, static members from Level are used rather than from Priority. I think that this is a regression.

        Activity

        Jingguo Yao created issue -
        Jingguo Yao added a comment -

        Patch available.

        Jingguo Yao made changes -
        Field Original Value New Value
        Attachment LOGGING-142.patch [ 12474781 ]
        Sebb added a comment -

        In 1.0.4, the code used both Level and Priority.

        The reason for this was that it was thought that log4j 1.3 was likely to change Level so it no longer extended Priority.
        However, 1.3 never really happened; 1.3 was only released as alpha code.

        Sebb added a comment -

        URL: http://svn.apache.org/viewvc?rev=1362982&view=rev
        Log:
        Replace deprecated field references

        Modified:
        commons/proper/logging/trunk/src/java/org/apache/commons/logging/impl/Log4JLogger.java

        Sebb made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.1.2 [ 12314498 ]
        Resolution Fixed [ 1 ]
        Thomas Neidhart made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        478d 1h 15m 1 Sebb 18/Jul/12 16:16
        Resolved Resolved Closed Closed
        245d 3h 55m 1 Thomas Neidhart 20/Mar/13 20:11

          People

          • Assignee:
            Unassigned
            Reporter:
            Jingguo Yao
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2h
              2h
              Remaining:
              Remaining Estimate - 2h
              2h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development