Uploaded image for project: 'Commons Logging'
  1. Commons Logging
  2. LOGGING-138

Show stacktrace for flawed discovery in diagnostic messages

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0, 1.1.1
    • Fix Version/s: 1.1.2
    • Labels:
      None

      Description

      It looks like since 1.1, if a custom log appender throws an exception the stack trace is not shown in diagnostic messages, making it harder (than 1.0.4) to find out the root cause of the log initialization problem.

      Here is a simple patch against the trunk to address the issue.

        Activity

        tn Thomas Neidhart added a comment -

        Added in r1448097.
        Used a StringWriter instead of your patch, thanks for the report!


          People

          • Assignee:
            Unassigned
            Reporter:
            vicaya Luke Lu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development