I haven't had a proper look at the code yet because of the work on the release , but I have a few thoughts.
I agree that it would be better to add a new attribute, rather than specifying "Object" for rendered class. Maybe just "defaultRenderer"? Do we plan to have any other renderers apart from object rendererds?
Looking at the naming, I would prefer that the renderer interface be called LoggerRenderer instead of LoggerRendererInterface. To keep the same naming scheme as LoggerConfigurator interface.
This is just some initial ideas. I will have a better look at the code for the weekend.