Uploaded image for project: 'Log4net'
  1. Log4net
  2. LOG4NET-649

MemoryAppender doesn't work on Alpine Linux with 2.0.10

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: 2.0.10
    • Fix Version/s: None
    • Component/s: Appenders
    • Labels:
      None
    • Environment:
      alpine linux 3.1.8-alpine3.12, dotnet core 3.1.

      Description

      Update:  I've also tested this with 2.0.11 and it still doesn't work correctly.

      We have unit tests that are testing to ensure that certain log errors and warnings are output.  We do this by setting up a memory appender in our test initialize.

      After upgrading to 2.0.10, memory appender never has any events.  We tried both PopAllEvents and GetEvents and neither return any events.

      Everything works fine on Windows, but doesn't work on Linux or Mac.

      Initialization code:
      var repo = LogManager.GetRepository(typeof(xxxx).Assembly);
      this.LogAppender = new MemoryAppender();
      BasicConfigurator.Configure(repo, this.LogAppender);

        Attachments

          Activity

            People

            • Assignee:
              davydm Davyd McColl
              Reporter:
              rakker91 Robert May
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: