Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.12
    • Component/s: None
    • Labels:
    • Environment:
      Windows

      Description

      Run PEVerify tool. (http://msdn.microsoft.com/en-us/library/62bwd2yd(v=VS.100).aspx)

      I get
      [IL]: Error: [log4net.dll : log4net.Plugin.RemoteLoggingServerPlugin::Attach][offset 0x00000029] Method is not visible.

      It is a good idea to add verification step for the build process.

      Thanks.

        Activity

        Stefan Bodewig added a comment - - edited

        This error is triggered by

        RemotingServices.Marshal(m_sink, m_sinkUri, typeof(IRemoteLoggingSink));

        and honestly I have no idea why.

        NN added a comment -

        Unfortunately me too.

        I have asked question in stackoverflow: http://stackoverflow.com/questions/8297419/log4net-verification
        But no answers.

        It would be great if you find the cause.
        Maybe bug in PEVerify ?

        Thanks.

        Stefan Bodewig added a comment -

        As an additional data point, peverify (of the 4.0 SDK) is happy with the dll built for .NET 2.0 which contains the same code inside the method, it only complains if the dll is compiled for .NET 4.0.

        NN added a comment -

        Yeah, it is very strange.
        What about IL code , is it the same as 2.0 and 4.0 compilation ?
        Maybe C# 4 compiler generates different IL.

        Btw, do you receive pull requests in github.com ?
        https://github.com/apache/log4net/pulls

        Stefan Bodewig added a comment -

        TBH I don't really intend to put too much effort into researching what may turn out as some compiler or peverify glitch. Not that I'd stop anybody else from trying to get it resolved.

        As for pull requests: those don't notify anybody (at least not for log4net). The better workflow is to create a patch and attach it to a JIRA issue.

        Dominik Psenner added a comment -

        Fixed as of revision: 1486895

        According to the answer posted at http://stackoverflow.com/questions/8297419/log4net-doesnt-pass-verification-when-compiling this should fix the reported PEVerify issue.


          People

          • Assignee:
            Dominik Psenner
            Reporter:
            NN
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development