Log4net
  1. Log4net
  2. LOG4NET-300

FilterTest doesn't compile for .Net 2.0

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.11
    • Fix Version/s: 1.2.11
    • Component/s: Other
    • Labels:
      None
    • Environment:
      .NET Framework 2.0 NAnt build on Windows

      Description

      Class MultiplePropertyFilter.Condition uses automatic properties which don't compile in a purce 2.0 environment like the one used when running the NAnt build.

      Fix is trivial and will be attached in a few seconds.

        Activity

        Stefan Bodewig made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Stefan Bodewig added a comment -

        fixed with svn revision 1158537

        Stefan Bodewig made changes -
        Field Original Value New Value
        Attachment filter_test_2.0.patch [ 12489955 ]
        Stefan Bodewig added a comment -

        Patch that makes FilterTest.cs compile on .NET 2.0

        Stefan Bodewig added a comment -

        Just saw the same class file also contains lambdas, I wonder whether it was intended to be 3.5 only.

        Will rewrite them as anonymous delegates.

        Stefan Bodewig created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Stefan Bodewig
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development