Log4net
  1. Log4net
  2. LOG4NET-294

Exception rendering object type [System.OutOfMemoryException]

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2.10
    • Fix Version/s: 1.2.12
    • Component/s: None
    • Labels:
      None
    • Environment:
      window2003 server, .Net framework 3.5. incorporated into Microsoft MOSS 2007Platform.

      Description

      configuration:
      <?xml version="1.0" encoding="utf-8"?>
      <log4net>
      <appender name="FatalFile" type="log4net.Appender.RollingFileAppender">
      <file value="Log directory" />
      <appendToFile value="true" />
      <rollingStyle value="Date" />
      <maximumFileSize value="10240KB" />
      <StaticLogFileName value="false" />
      <maxSizeRollBackups value="10" />
      <datePattern value=".yyyy-MM-dd".log"" />
      <layout type="log4net.Layout.PatternLayout">
      <conversionPattern value="time:%date threadID:[%thread] level:%-5level class:%logger property:[%property

      {NDC}

      ] - decription:%message%newline" />
      </layout>
      </appender>
      <logger name="DEBUGGER" additivity="false">
      <level value="ALL" />
      </logger>
      <root>
      <level value="FATAL" />
      <appender-ref ref="FatalFile" />
      </root>
      </log4net>

      Error Stack:
      <log4net.Error>Exception rendering object type [System.OutOfMemoryException]<stackTrace>System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown.
      at log4net.ObjectRenderer.DefaultRenderer.RenderObject(RendererMap rendererMap, Object obj, TextWriter writer)
      at log4net.ObjectRenderer.RendererMap.FindAndRender(Object obj, TextWriter writer)</stackTrace></log4net.Error>

      Note:
      This error doesn't always shows. We're not sure what effect will push on our application by this issue. We also notice that some one report this issue here:https://issues.apache.org/jira/browse/LOG4NET-192
      But the resolution said 'Cannot Reproduce'. Now, ii reproduced again.

        Activity

        Dominik Psenner added a comment - - edited

        Did you try to render a particularily large object (i.e. a huge dictionary or enumerable)? Did the out of memory exception raise before you added log4net to your project? With the information given we are unable to reproduce the issue.

        Dominik Psenner added a comment -

        Cannot reproduce the issue and closing the issue due to no activity.


          People

          • Assignee:
            Dominik Psenner
            Reporter:
            xiaofeng chen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development