Log4net
  1. Log4net
  2. LOG4NET-200

Log4Net Dll stops logging after 1 or 2 days

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 1.2.10
    • Fix Version/s: None
    • Component/s: Appenders
    • Labels:
      None
    • Environment:
      IIS 6.0
      Windows server 2003 (SP1)
      .Net Framework 2.0 Web Application

      Description

      Observation : The Log4Net service stops logging after 1 or 2 days

      Server reboot fixes the problem.
      IIS services reboot doesn't fix the problem.

      The internal debug mode doesn't give us any information, because of the problem is not reproductible.

      We use the RollingFileAppender and EventLogAppender classes.

      Have you any information about this (general) issue ?

      Thank you
      Regards

        Issue Links

          Activity

          Ron Grabowski added a comment -

          Have you thought about writing an error handler that sends an email when an appender goes offline?

          public class SendMailOnceErrorHandler : IErrorHandler
          {
          private bool firstTime = true;

          public void Error(string message, Exception e, ErrorCode errorCode)
          {
          if (firstTime)
          {
          // sendMail(message, e, errorCode);
          firstTime = false;

          if (LogLog.InternalDebugging && !LogLog.QuietMode)

          { LogLog.Error(declaringType, "[" + m_prefix + "] ErrorCode: " + errorCode.ToString() + ". " + message, e); }

          }
          }

          public void Error(string message, Exception e)

          { Error(message, e, ErrorCode.GenericFailure); }

          public void Error(string message)

          { Error(message, null, ErrorCode.GenericFailure); }

          }

          Ron Grabowski added a comment -

          There hasn't been any additional comments on this item since 2/2009.

          I'll finish out SendMailOnceErrorHandler and move that into the examples folder in svn.

          Noam Helfman added a comment -

          I'm observing the same issue as well.

          System: IIS 7.5, log4net 1.2.10

          Stefan Bodewig added a comment -

          sounds as if the problem hasn't been fixed so far

          Stefan Bodewig added a comment -

          Nothing has been changed in svn for this issue and there still are reports that indicate the problem exists (albeit without being reproducable)

          Matthew Schneider added a comment -

          Sounds like this might be the same as LOG4NET-178.
          The default ASP.NET Application Pool setting is to recycle after 1740 minutes (29 hours).

          Dominik Psenner added a comment -

          I agree with Matthew Schneider that this sounds like a duplicate of LOG4NET-178. Feel free to reopen the issue if that's not the case.


            People

            • Assignee:
              Dominik Psenner
              Reporter:
              Christophe Chevalier
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 96h
                96h
                Remaining:
                Remaining Estimate - 96h
                96h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development