Log4j 2
  1. Log4j 2
  2. LOG4J2-440

exception on shutdown tomcat in Mac OSX

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta9
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None
    • Environment:

      Mac OSX (Mountain or Mavericks).

      Description

      Apache Tomcat 7.0.47 throws exceptions (class not found for org.apache.logging.log4j.core.config.NullConfiguration) but only happens when shutdown tomcat process.

        Issue Links

          Activity

          Matt Sicker added a comment -

          Was fixed.

          Erico Seberino da Silva Júnior added a comment -

          apparently was corrected

          thanks !

          Erico Seberino da Silva Júnior added a comment -

          i will try again soon!

          Em sábado, 1 de março de 2014, Ralph Goers (JIRA) <jira@apache.org>

          Ralph Goers added a comment -

          Erico - is this still a problem with 2.0-rc1?

          Remko Popma added a comment -

          Erico, I agree with Matt's assessment.
          Could you try building from trunk to see if the problem still exists?

          Matt Sicker added a comment -

          This looks like a duplicate of something that was just fixed.

          Erico Seberino da Silva Júnior added a comment -

          jar files:

          • log4j-api-2.0-beta9.jar
          • log4j-core-2.0-beta9.jar

          log4j2.xml file:

          <?xml version="1.0" encoding="UTF-8"?>
          <configuration status="warn">
          <appenders>
          <Console name="console" target="SYSTEM_OUT">
          <ThresholdFilter level="all" />
          <PatternLayout charset="UTF-8" pattern="%d

          {dd/MM/yyyy HH:mm:ss.SSS}

          [%t] %-5level %logger:%L - %m%n%throwable

          {full}" />
          </Console>
          <RollingFile name="rollingfile" fileName="/Applications/tomcat7/logs/webkit.log" filePattern="/Applications/tomcat7/logs/webkit-%d{yyyy-MM-dd}.log.zip">
          <ThresholdFilter level="warn" />
          <PatternLayout charset="UTF-8" pattern="%d{dd/MM/yyyy HH:mm:ss.SSS} [%t] %-5level %logger:%L - %m%n%throwable{full}

          " />
          <Policies>
          <TimeBasedTriggeringPolicy />
          </Policies>
          <DefaultRolloverStrategy max="30" />
          </RollingFile>
          </appenders>
          <loggers>
          <logger name="org.apache.catalina.connector.ClientAbortException" level="all" additivity="false">
          <appender-ref ref="console"/>
          </logger>
          <root level="all">
          <appender-ref ref="console" />
          <appender-ref ref="rollingfile" />
          </root>
          </loggers>
          </configuration>

          Erico Seberino da Silva Júnior added a comment - - edited

          Here is the exception:

          Nov 07, 2013 11:44:22 PM org.apache.catalina.core.StandardServer await
          Informações: A valid shutdown command was received via the shutdown port. Stopping the Server instance.
          Nov 07, 2013 11:44:22 PM org.apache.coyote.AbstractProtocol pause
          Informações: Pausing ProtocolHandler ["http-bio-8080"]
          Nov 07, 2013 11:44:22 PM org.apache.catalina.core.StandardService stopInternal
          Informações: Stopping service Catalina
          Nov 07, 2013 11:44:22 PM org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
          Grave: The web application [] appears to have started a thread named [Abandoned connection cleanup thread] but has failed to stop it. This is very likely to create a memory leak.
          Nov 07, 2013 11:44:22 PM org.apache.catalina.core.ApplicationContext log
          Informações: SessionListener: contextDestroyed()
          Nov 07, 2013 11:44:22 PM org.apache.catalina.core.ApplicationContext log
          Informações: ContextListener: contextDestroyed()
          Nov 07, 2013 11:44:22 PM org.apache.coyote.AbstractProtocol stop
          Informações: Stopping ProtocolHandler ["http-bio-8080"]
          Nov 07, 2013 11:44:22 PM org.apache.coyote.AbstractProtocol destroy
          Informações: Destroying ProtocolHandler ["http-bio-8080"]
          Exception in thread "Thread-3" java.lang.NoClassDefFoundError: org/apache/logging/log4j/core/config/NullConfiguration
          at org.apache.logging.log4j.core.LoggerContext.stop(LoggerContext.java:210)
          at org.apache.logging.log4j.core.LoggerContext$ShutdownThread.run(LoggerContext.java:437)
          Caused by: java.lang.ClassNotFoundException: org.apache.logging.log4j.core.config.NullConfiguration
          at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1714)
          at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1559)
          ... 2 more

          Gary Gregory added a comment -

          and the log4j and app configuration files and classpath.

          Remko Popma added a comment -

          Do you have a stack trace?


            People

            • Assignee:
              Unassigned
              Reporter:
              Erico Seberino da Silva Júnior
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development