Uploaded image for project: 'Log4j 2'
  1. Log4j 2
  2. LOG4J2-3428

Update 3rd party dependencies for 2.18.0

    XMLWordPrintableJSON

Details

    • Task
    • Status: Open
    • Major
    • Resolution: Unresolved
    • None
    • 2.18.0
    • Build
    • None

    Description

      This ticket should only be closed when we release 2.18.0.

      The updated dependencies are:

      • com.datastax.cassandra:cassandra-driver-core from 3.1.4 to 3.11.2
      • com.h2database:h2 from 1.4.200 to 2.1.212
      • com.fasterxml.jackson.core:jackson-annotations 2.13.1 -> 2.13.3
      • com.fasterxml.jackson.core:jackson-core 2.13.1 -> 2.13.3
      • com.fasterxml.jackson.core:jackson-databind 2.13.1 -> 2.13.3
      • com.fasterxml.jackson.dataformat:jackson-dataformat-xml 2.13.1 -> 2.13.3
      • com.fasterxml.jackson.dataformat:jackson-dataformat-yaml 2.13.1 -> 2.13.3
      • com.fasterxml.jackson.module:jackson-module-jaxb-annotations 2.13.1 -> 2.13.3
      • com.google.guava:guava-testlib 31.0.1-jre -> 31.1-jre
      • com.ibm.icu:icu4j from 4.6.1 to 71.1
      • de.flapdoodle.embed:de.flapdoodle.embed.mongo 3.4.1 -> 3.4.6
      • io.fabric8:kubernetes-client from 5.12.1 to 5.12.2
      • org.apache.felix:org.apache.felix.framework from 7.0.3 to 7.0.4
      • org.apache.maven:maven-core 3.8.4 -> 3.8.5
      • org.awaitility:awaitility 4.1.1 -> 4.2.0
      • org.codehaus.groovy:groovy-dateutil 3.0.9 -> 3.0.10
      • org.codehaus.groovy:groovy-jsr223 3.0.9 -> 3.0.10
      • org.codehaus.plexus:plexus-utils from 3.4.1 to 3.4.2
      • org.elasticsearch.client:elasticsearch-rest-high-level-client from 7.17.3 to 7.17.4
      • org.jctools:jctools-core from 1.2.1 to 3.3.0
      • org.junit-pioneer:junit-pioneer from 1.6.1 to 1.6.2
      • org.mockito:mockito-core from 4.3.1 to 4.4.0
      • org.mockito:mockito-junit-jupiter from 4.3.1 to 4.4.0
      • org.osgi:org.osgi.core from 4.3.1 to 6.0.0
      • org.springframework:spring-aop from 5.3.16 to 5.3.20
      • org.springframework:spring-beans from 5.3.16 to 5.3.20
      • org.springframework:spring-context from 5.3.16 to 5.3.20
      • org.springframework:spring-context-support from 5.3.16 to 5.3.20
      • org.springframework:spring-core from 5.3.16 to 5.3.20
      • org.springframework:spring-expression from 5.3.16 to 5.3.20
      • org.springframework:spring-oxm from 5.3.16 to 5.3.20
      • org.springframework:spring-test from 5.3.16 to 5.3.20
      • org.springframework:spring-web from 5.3.16 to 5.3.20
      • org.springframework:spring-webmvc from 5.3.16 to 5.3.20
      • org.springframework.ws:spring-ws-core from 3.1.2 to 3.1.3
      • org.zeromq:jeromq from 0.4.3 to 0.5.2

      Attachments

        Activity

          People

            Unassigned Unassigned
            ggregory Gary D. Gregory
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated: