Uploaded image for project: 'Log4j 2'
  1. Log4j 2
  2. LOG4J2-265

FlumeAppender Stops App from Shutting Down when Newer Version of Netty is Used

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0-beta6
    • Fix Version/s: None
    • Component/s: Appenders
    • Labels:
      None

      Description

      FlumeAppender(log4j-flume-ng) depends on flume-ng-sdk, which uses netty-3.4.0.Final. When a higher version of netty is used instead, such as 3.5.8.Final or 3.6.5.Final, FlumeAppender will not shutdown properly.

      To reproduce the problem (use attached Maven project):
      1. Start your remote flume agent
      2. Change the log4j2.xml to your agent host and port
      3. press x and hit Enter

      Notice how the application continues to run. Press x should break out of the main loop and return from main(), indicating that the application should close.
      The thread holding things up are
      Hashed wheel timer #1
      New I/O worker #1-8

        Activity

        ejsarge Edward Sargisson added a comment -

        Hi Jim,
        This very much reminds me of FLUME-2002 - which is fixed in Flume 1.4-SNAPSHOT.
        Would you be able to re-run your test against that version and, if still broken, raise this Jira against the Flume project?
        We'll be very interested over there to take a look.

        ralph.goers@dslextreme.com Ralph Goers added a comment -

        There is no way to fix this issue in the Flume Appender. It must be fixed in Flume.

        jimtang Jim Tang added a comment -

        Hi Ralph, I have changed the attachment to zip formant

        ralph.goers@dslextreme.com Ralph Goers added a comment -

        I don't have 7-zip for OSX and can't seem to find a current one. Can you please use zip or gzip?

        I will test this once I can unarchive the attachment, however since the FlumeAvroManager now just uses the Flume RPC Client this is most likely something that will have to be fixed in Flume.


          People

          • Assignee:
            Unassigned
            Reporter:
            jimtang Jim Tang
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development