Propose to rename AsynchAppender to AsyncAppender.
In addition rename the plugin name for that appender from Asynch to Async.
Reasons for renaming:
- consistency with Log4j-1.x and Logback naming
- consistency with Log4j-2.0 Async Loggers naming
- personal preference
As per discussion on the mailing list, we can still make this change since we are still in beta.