We ran into a problem when setting locationInfo to true when ingesting logs into Kibana. The problem had to do with a conflict with another existing key named "source" of type String, and the fact that locationInfo produces an Object called "source".
So it would be nice to have a way to supply a different Object name. Perhaps this could be broadened so that other key names could also be renamed?
Maybe there is a way to do this already?