Uploaded image for project: 'Log4j 2'
  1. Log4j 2
  2. LOG4J2-2133

Log4J 2 appears incompatible with Android platform due to inclusion of Java 9 classes (class file version 53)

    XMLWordPrintableJSON

    Details

    • Type: Wish
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.9.1, 2.10.0
    • Fix Version/s: None
    • Component/s: API
    • Labels:
      None

      Description

      Log4J 2 appears incompatible with Android platform due to inclusion of Java 9 classes (class file version 53). Please see screenshot attached.

      I fully admit that there might be a way to make Android ignore those files but it is still disheartening that Log4J 2 APIs have dependencies on things that go beyond providing a thin logging abstraction layer.

      Oleg

        Attachments

        1. Screenshot from 2017-11-28 09-41-37.png
          49 kB
          Oleg Kalnichevski

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                olegk Oleg Kalnichevski
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated: